Switching to another theme

  • Author
    Posts
  • #209248

    pohaver
    Member

    I tried to switch my site to another theme, but most of them change how my home page is displayed. It no longer comes up as my home page. What changes do I have to make, to use a new theme and restore my home page?

    #209351

    isadora
    Member

    Please provide a link to your blog, so that we can have a look at what you mean by “home page”.

    #209359

    pohaver
    Member

    It’s a “page” not a Post. http://www.safesoccer.com will connect to safesoccer.wordpress.com

    #209369

    isadora
    Member

    Actually changing theme shouldn’t remove to static page from the front, but some themes might show two “home” links on the top navigation. If this is the case, look here for a solution: http://faq.wordpress.com/2007/07/01/i-have-2-home-page-links/
    If the options really gets “lost” on switching theme, then you just have to set the option again under “Options” > “Reading” as described here: http://faq.wordpress.com/2007/02/20/having-a-static-page-at-the-front-of-the-blog/

    #209415

    pohaver
    Member

    If I apply the changes to a new theme, can I change back if it doesn’t turn our like I want?

    #209424

    raincoaster
    Member

    Of course.

    #209592

    pohaver
    Member

    I am confused. I checked the page that I want to be my home page and it is in the parent box, but not reference to the new “home page” that the new theme added. I just want one of the two tabs in the navigation panel to go away as long as my content is there, it doesn’t matter which tab shows. my site is: safesoccer.com which will connect to safesoccer.wordpress.com.

    #209595

    isadora
    Member

    Well, if you managed to put a static page in front of your blog (say: “Soccer Safety-Home”), then you must have defined a page name for your blog posts (for example: “blog”). Now:
    To fix that, go to Manage > Pages and edit the Page you have chosen to be the front page. In my example: “Soccer Safety-Home”
    Look on the right for the ‘Page Parent’ box.
    Open it and make that page the child of the Posts page you chose
    in my example: “blog” – so make the Posts page its Parent.

    #209616

    pohaver
    Member

    when I am in the edit window for my home page the parent window only has two options, “home page-no parent” and “about the author” which is the only other page I have. Everything else is a post. I don’t know how to make a change in the page parent.

The topic ‘Switching to another theme’ is closed to new replies.