table border and image (100%) with caption

  • Author
    Posts
  • #641644

    jensonyu
    Member

    This is likely theme related issue. Example page: http://jensonyu.wordpress.com/2011/06/26/cathedrale-de-notre-dame/

    I have two tables (set up the same way) with only one attribute: style=”border:0px;” Any yet, there is thin border on each row.

    2nd issue: with an image displayed at Center, Full Size (example: bottom two images in that post), the right border is cut off of the page.

    The blog I need help with is jensonyu.wordpress.com.

    #641833

    timethief
    Member

    This will help override border HTML tables http://wpbtips.wordpress.com/2010/06/15/overriding-table-borders/

    #641834

    timethief
    Member

    I’m using Firefox 5 and can’t see the right border being cut off. Which browser and version of it are you using?

    The maximum displayed images widths by theme are found here > http://wpbtips.wordpress.com/2009/07/23/maximum-image-width/

    #641846

    jensonyu
    Member

    OK, I applied the border fix and it worked. But I want to know if that’s the “official fix” or just a temporary work-around. Will WordPress eventually resolve this issue for those themes? It’s bothersome to do it for each single cell.

    I have tried (on Mac) Safari 5, FIrefox 5 and Chrome 12. They all have same issue. When it’s set to Full Size (645×428), there is no problem if there is no caption for that image. It’s only after I added the caption, the page wraps the image + the caption with a thin border line. Top, left and bottom borders are there, except the right side.

    The 644px instead of 645px issue mentioned in the tips blog could be the culprit here. But how do I fix it? I am fine not to have the border at all. But how would I remove that?

    #641847

    jensonyu
    Member

    On another note, how come there is no “insert table” in the tool bar and we’re forced to hand-code such a common element in HTML view?

    #641859

    timethief
    Member

    @jensonyu
    Re: Official fix or temporary workaround? Will WordPress eventually resolve this issue for those themes? It’s bothersome to do it for each single cell.

    I’m sorry I don’t know. I just use what works. You will have to contact Staff for an ans as we Volunteers have no idea what they plan to do or not do. You can contact them when they reactivate the support link at 12PM UTC on Monday 27th June. http://en.support.wordpress.com/contact/

    Re: It’s only after I added the caption, the page wraps the image + the caption with a thin border line. Top, left and bottom borders are there, except the right side.
    I could be wrong but that sounds like caption bug to me I suggest you report it.

    Re: how come there is no “insert table” in the tool bar and we’re forced to hand-code such a common element in HTML view?
    There is no insert table, change fonts, change backgrounds etc. in the editor because WordPress.com does not choose to use equip the editor with some functions that moxiecode who provide the Tiny MCE offer. We get the basic editor.

    P.S. If we use windowslivewriter we can create tables in it and post to our blogs from it. We can also use table generators online and copy paste.

    #641917

    @jensonyu: The widths listed in my post are for non-captioned images. For captioned images the correct maximum is lower, because of the extra frame. Go to Settings>Media, set 602 as the Max Width for the Large option, and use that option instead of Full Size when inserting captioned images.

    #641938

    jensonyu
    Member

    Thanks, @panaghiotisadam and @timethief. After some experiments, I found 624 is the max it can use for captioned images.

    #641940

    timethief
    Member

    @jensonyu
    You’re welcome from me. :)

The topic ‘table border and image (100%) with caption’ is closed to new replies.