Text format chaotic

  • Author
    Posts
  • #28949

    trickstar
    Member

    Hi,

    as you can see in my last post in my blog, somehow the online-editor inserts line-breaks where i don’t want any, and completely messes up the layout. As this hasn’t happened before, and I can’t resolve it on my own, any help would be nice.

    cya
    Andreas

    #29169

    cornell
    Member

    Are you doing a copy and paste from MS Word (or similar)?

    This can cause the strange formatting that you are seeing. Try using notepad instead.

    If it’s not that then try turning off the Rich Text Editor in your dashboard and see if that helps.

    Collin

    #29170

    rsathya
    Member

    sometimes text alongside a picture in html could become really tricky. This is y most ppl prefer switching off the rich text editer and do stuff directly with html.
    u might want to look at the html code to make sure its good.
    U might find this link useful

    Sathya

    #29189

    drmike
    Member

    Actually I don’t see any line breaks in the page source.

    This might be another case of the rich text editor going wonky again though.

    #29279

    trickstar
    Member

    yeah, i don’t use any word or other crappy software, i tried editing the source itself, and i know all about alignment, doesn’t help at all.
    it’s just that the editor keeps inserting line breaks, where i don’t want any, and i can’t prevent it from doing so. i can’t even find a pattern where and why these breaks are inserted, so i still need help on that.

    #29281

    andyc
    Member

    I have an occasional but very irrtating problem with the Rich Text Editor. Sometimes mid-post, the ‘DELETE’ and ‘BACKSPACE’ keys simply stop working.

    When your typing is as bad as mine, this becomes very tiresome :-)

    If I save the draft and re-edit, the issue sometimes goes away. Other times I have to restart the browser.

    FF 1.5.0.6, Windows XP

    #29282

    raincoaster
    Member

    Very odd. I always use the RTE and have never had that issue, although I use IE mostly. I DO have a recurring problem with having to paste images twice, though.

    #29480

    nomdebplume
    Member

    Cornell-
    Cutting and pasting from MS Word is what makes my text need reformatting repeatedly? Is the same true for WordPerfect? (I don’t like typing directly into the editor and don’t care for Notepad, either – that’s why I ask.)

    Also (and just tell me if I need to go to another thread for this), does anyone know why my sidebar insists on placing itself all the way at the bottom of my page? It can’t be seen unless someone scrolls to my first post (which, granted, as a newbie, isn’t that far… but still… :-)
    Thanks!

    #29481

    timethief
    Member

    The only wordprocessing programs that donot add in uneccessary formatting and style code is a “plain text editor” like NotePad. Both WORD and WORDPERFECT add stuff that the wordpress program has to strip out.

    If you don’t care for NotePad then you can

    (1) turn off the text rich editor -> dashboard -> profile -> uncheck the visual rich editor box

    http://wordpress.com/forums/topic.php?id=3223&replies=55

    (2) you can download BlogDesk free from the net and use it (it’s very easy to use) and it will upload your posts into your blog with the formatting you choose. It provides the neccesary html after you input just the text without the coding.

    (3) If you sidebar is dropping to the bottom of the page it’s usually because you have an oversized image in your blog. If you reduce the image size it will correct. I just looked at your sidebar. It’s fine from what I can see.

    #29483

    nomdebplume
    Member

    Thanks for the info, Timethief… much appreciated.

    Regarding the sidebar, I’m going to assume it looks different to everyone else than it does to me (?), but I’ll keep your tip in mind all the same. Thanks for taking the time to check.

    #29484

    raincoaster
    Member

    I can see why your sidebar is dropping, but I’m inclined not to tell you because you were disrespectful to Jon “World’s Greatest Living American” Stewart.

    Aw, heck, it’s because you put in a link that is too long and it is going over to the right-hand side where the sidebar would be. Make a shorter link, like this one and the problem will be fixed.

    #29492

    nomdebplume
    Member

    Raincoaster-
    I know how hard it must have been for you to help me with my sidebar problem after reading my blog, but I really do appreciate it! I collect knowledge from every source I can get it, including Jon Stewart fans… wink, wink.
    Thanks for sharing your expertise with me, despite your initial inclination not to.

    #29495

    raincoaster
    Member

    You’re welcome. Just don’t tell the Democratic Underground!

    #29498

    timethief
    Member

    *snort*

    #29501

    trickstar
    Member

    I don’t even use the RTE, still the same problem. pleeeeeease help me.

    #29502

    trickstar
    Member

    ok, i finally found the error. it seems that some of the spaces in my first posting of this blog-entry have been turned into some kind of special non-break-spaces somehow, but it showed neither in the plain text editor nor in the html-editor. so what i did is replace all the spaces with “new” spaces, as absurd as it sounds, it worked. This website has some strange “features” ;)

    #29503

    raincoaster
    Member

    That’s very odd. Never heard of that happening.

The topic ‘Text format chaotic’ is closed to new replies.