Text Widgets @ Bottom Page in Explorer, OK in Firefox

  • Author
    Posts
  • #411954

    mpustka
    Member

    http://austxrealestate.wordpress.com

    When viewing my blog in Explorer, Austin Home Search, Loopnet and Linked In text widgets are showing up in double columns on the right. In Firefox they are in a singular column as I want them to look.

    Twitter, Blogroll, Category Cloud, Tag Cloud are all located at the bottom of the page in Explorer but are like I want them in Firefox.

    I looked at the Themes > Layout Issues support Post but still couldn’t figure out how to rectify.

    Thanks for any help or direction.

    The blog I need help with is austxrealestate.wordpress.com.

    #412091

    It’s the tables in your latest post. Notice how they go under the sidebar widgets?

    You are going to have to arrange them vertically, one underneath the other.

    #412095

    mpustka
    Member

    If I change the post with the tables to “draft” such that it no longer shows up on the front page – the problem still is there.

    #412096

    I’m not sure where to start. You have 54 errors on your main page alone. All kinds of missing HTML tags and such are being reported.

    Go to settings > writing and select “WordPress should correct invalidly nested XHTML automatically” and click “save changes.”

    Next open each post on your main blog page, make one minor change such as adding a space and then deleting it, and then click “update post. WordPress should automatically correct any HTML issues in the posts and fix the issue.

    If that doesn’t do it, then you are going to have to slog through all your text widgets in the sidebar and look for bad code or missing tags.

    #412097

    mpustka
    Member

    Thanks

    #412103

    mpustka
    Member

    OK, went through the posts and did the edits you suggested and didn’t help.

    What sort of code problems am I looking for in the widgets?

    I typically put them together using the draft post function and the cut and paste the html to the text widget.

    #412107

    On another issue: As we’ve told you before, don’t use tags identical to your categories. See why here:
    https://en.forums.wordpress.com/topic/change-category-name?replies=7#post-393514

    #412114

    One thing I see is in this post, Austin Economic Indicators, at the bottom below the table of images is this:

    <p style="text-align:center;">
    <p style="text-align:center;"><a href="http://www.austin-chamber.org/DoBusiness/MediaCenter/reports/EconomicIndicatorsSlides.pdf"><br />
    </a></p>
    <p style="text-align:center;">
    <p style="text-align:center;">
    
    <p style="text-align:center;">
    <p style="text-align:center;">
    <p style="text-align:center;">
    <p style="text-align:center;">
    <p style="text-align:center;"> </p>

    See the break after the PDF link? It should not be within the hyperlink code, and there is no text to function as a link.

    Notice all the <p style=”text-align:center;”> with no closing tags? Get rid of all of those.

    It should look something like this when you are finished:

    <p style="text-align:center;"><a href="http://www.austin-chamber.org/DoBusiness/MediaCenter/reports/EconomicIndicatorsSlides.pdf">Economic Indicators Slides</a></p>

    You need to go through all your posts in the HTML tab and see if there are other such instances.

    You also need to do something with that table that is hidden below the sidebar. What good is having it in there if people cannot read what is hidden?

    One thing you can do is set your blog to show only one post per page (settings > reading) and then go through all the posts in IE using the previous post link at the bottom of the page to see which posts break the blog.

    #412135

    mpustka
    Member

    ok thanks for the direction, I’ll see what I can figure out.

    #412214

    mpustka
    Member

    Twitter and everything that was dumping to the bottom of the page is now where it should be on the right side column.

    My only issue now is that Austin Home Search / Loopnet / Trulia / and Linked In text widgets are supposed to be in a singular column but they are rolling over into a second column.

    Is there a way to anchor these text widgets to the left?

    I have them set up with a left align but that doesn’t seem to help.

The topic ‘Text Widgets @ Bottom Page in Explorer, OK in Firefox’ is closed to new replies.