The "Copy a Post" feature no longer works

  • Author
    Posts
  • #3190832

    bateau4u
    Member

    The “Copy a Post” feature no longer works on my blog.

    I have created templates of various posts that I have regularly copied over the years. However, now when I click the Copy a Post button all I get is a blank “Add New Post.”

    Has WordPress removed this valuable feature, or is there something funky going on with my browser?

    Divinity’s Dad

    The blog I need help with is missdivinity.wordpress.com.

    #3190839

    Perhaps you could try a different browser to check. That option displays for me in the My Sites/Calypso dashboard, the classic /wp-admin dashboard and Gutenberg:
    https://en.support.wordpress.com/posts/copy-a-post/

    #3190847

    bateau4u
    Member

    I’ll try that, thanks!

    #3191272

    bateau4u
    Member

    I should have stated that I use the Old Editor as I find it preferable over the new version.

    Rechecking the Old Editor I no longer have the opportunity to “copy” a post. The “Copy a Post” link opens up a blank template.

    I did check the New Editor and find that I can “Duplicate” a post. I suppose that I could duplicate a post and then open it up in the Old Editor.

    Divinity’s Dad

    #3191331

    Where are you clicking on “copy a post”? On the black lefthand menu? (which leads to what may be the Gutenberg editor). That doesn’t work for me either. In /wp-admin if you click “All posts” on the black menu then at “Posts” “Add new” in the grey to the right and click the arrow to select the classic editor then you finally get to the real classic/wp-admin editor and “Copy a post” works. I have tagged this for staff as there does seem to be an issue.

    #3191354

    Morning folks –

    Thanks for the tag, themagicrobot.

    bateau4u – I want to be certain I am at the same part in my dashboard trying to replicate your report. Are you able to grab a screen shot of where you find the “duplicate post” button? Add it here through a third party link like CloudUp or droplr. The other option is to add it on the site’s media library and I can take a look from there as well.

    #3191458

    Afternoon/evening (here) Lizkarkoski.
    The “Copy a post” function in the Calypso “Blog posts” “add” “Post settings” works. And confusingly in “Blog Posts” just going to the three dots toggle menu and clicking “Duplicate” (which I’d never noticed before) seems to perform the same function as “Copy a post”. It’s just since the recent changes in /wp-admin/post-new.php that “Copy a post” doesn’t do anything. Using /wp-admin/post-new.php?classic-editor everything works fine.

    #3191468

    bateau4u
    Member

    Here is the URL that “Copy a Post” now has.

    https://missdivinity.wordpress.com/wp-admin/post-new.php?cap#cap

    Here are the two images I uploaded to my media library for you.

    * Old Editor – Copy a Post

    * From Copy a Post – No previous Posts to Copy

    #3191472

    And have you checked if it still works for you in the real old editor? /wp-admin/post-new.php?classic-editor

    #3191476

    bateau4u
    Member

    I checked less than an hour ago.

    That’s when I took those screen shots I uploaded to my media library!

    #3191480

    Well we’ll have to wait until @lizkarkoski returns to this thread and can check your screenshots then to see exactly where in the dashboard you are.
    I still maintain that using the black lefthand menu /wp-admin/post-new.php doesn’t work but using the dropdown arrow to reach the classic dashboard /wp-admin/post-new.php?classic-editor does. (We’re probably back to javascript issues that made it so difficult for me to use the Calypso dashboard when that was first introduced).

    #3191747

    bateau4u
    Member

    I have been using the “Copy a Post” feature from the “OLD EDITOR” for years. Especially for my regular “Senior Sunday” posts, and for my “Joins the Country List” posts.

    I believe the change to the “Copy a Post” link occurred sometime between Sep 23, 2018, and Sep 30, 2018. However, I might be off a bit by a few days.

    The post I published last Sunday (Sep 30, 2018) was not created using the “Copy a Post” feature as it no longer worked. I had to manually open my “Senior Sunday” template, and copy & paste all the text into a new blank post by clicking the “Add New” link.

    However, the previous “Senior Sunday” (Sep 23, 2018) post WAS created using the “Copy a Post” link in the OLD Editor.

    As I have previously stated, clicking the “Copy a Post” link now only creates a NEW blank post page! I am no longer able to “Copy a Post,” and I am no longer able to view any posts after I click the “Copy a Post” link.

    The NEW behavior is now no different than if I clicked the “Add New” link!

    It would help if I could just attach screen shots of what I am talking about, but I do not do Cloud anything, so we’ll have to wait until a MED looks at my media library.

    Thank you for all your help, it is very much appreciated!

    #3191766

    I still maintain that using the black lefthand menu /wp-admin/post-new.php doesn’t work but using the dropdown arrow to reach the classic dashboard /wp-admin/post-new.php?classic-editor does.

    #3191792

    bateau4u
    Member

    I’ve been using the OLD Editor since I created my blog back in 2009. I tried the NEW Editor when it came out and didn’t like it at all. I immediately went back to the OLD EDITOR and have used it ever since to write my blog posts.

    The only use I have for the New Editor is to log in, and check my stats. Nothing else.

    In the past nine-years, I’ve used the “Copy a Post” feature on that editor hundreds of times.

    The “Copy a Post” feature did work up till the past few weeks!

    #3191826

    There is the new editor – My Sites/Calypso

    There are now two different wp/admin editors as I explained earlier.

    #3192535

    bateau4u
    Member

    The Calypso editor is the New Editor I’ve mentioned here and have stated I do not like it.

    Also, as I have stated multiple times the “Copy a Post” feature in the Old Editor DID work up till recently. It now only creates a New blank post.

    Obviously, you have not been using the Old Editor or you would have know that.

    I really appreciate your trying to help, but it seems I’ll need to wait until @lizkarkoski is able to look at my media library.

    Thank you again!

    Divinity’s dad

    #3192553

    I don’t think you have read anything I have previously written. I have been using WordPress.org and WordPress.com for the last twelve years and am able to distinguish between editors. Are you? As I have stressed before if you use the classic wp/admin editor “Copy a Post” works fine. (Posts add new and arrow down to choose “classic”). If you use the “My Sites/Calypso” editor it works fine. But if you use what used to be the /wp-admin post editor via the black lefthand menu (that has recently been “improved” and is now Gutenberg and not the classic editor) “Copy a Post” currently doesn’t work.

    #3192587

    bateau4u
    Member

    I have read your posts and you are wrong, but it seems your ego won’t let you admit it.

    As for experience, I spent nearly two decades in high-tech, mostly in software including API and security software, and I do know what I am talking about.

    One last time, in the OLD Editor the “Copy a Post” feature no longer works. I tried it again this morning and all it did was open a NEW Blank Post page!

    Please go help someone else, you are adding nothing helpful in this thread!

    #3192594

    Please go help someone else, you are adding nothing helpful in this thread!

    You’re very welcome. It’s been a pleasure. I have added the modlook tag again for staff assistance.

    PS: Perhaps someone from staff could explain that two separate versions of the wp-admin post editor have recently become available ie:
    /wp-admin/post-new.php
    and:
    /wp-admin/post-new.php?classic-editor

    #3192867

    supernovia
    Staff

    Hi @bateau4u, I couldn’t see your screenshot very well. It was a crop of the screen (missing some details that would have been useful) and the text was too small to read clearly, so if you wouldn’t mind uploading a larger one that would be useful.

    Also, please go to Screen Options (at the top) and ensure you have Writing Helper enabled.

    And, let us know if you’re able to choose a post to copy at https://missdivinity.wordpress.com/wp-admin/post-new.php?cap#cap

You must be logged in to reply to this topic.