The Morning After – Limit Featured Posts

  • Author
    Posts
  • #595871

    joliver
    Member

    Is there a way to limit the number of featured posts on my home page? I love the theme, but the home page displays every post I’ve made since I started the blog and the loading time has taken a hit because of it. I have tried limiting the amount of posts under the Reader Settings, but that did not work. Thanks for any help.

    The blog I need help with is dazedrambling.wordpress.com.

    #596064

    timethief
    Member

    Volunteers cannot help you with this. Please report this to Staff > http://en.support.wordpress.com/contact/

    #596068

    joliver
    Member

    Thank you. Have done. :)

    #596069

    timethief
    Member

    You’re welcome. There’s another member experiencing the same problem and I won’t be surprised if more don’t trickle into the forum.

    #596070

    i actuall like this theme more than my premium theme. However, i too would like to know how to remove the “featured posts and simply have 6-7 of the most recent posts. sticky is not designated, yet all are treated as such.

    #596071

    joliver
    Member

    I am somewhat surprised no one posted before I did. I try to exhaust all avenues before resorting to support. I spent most of the afternoon searching for a way to limit the posts, but the theme is just too new to find much information on it. I believe I saw mention of a way to limit posts in the self-hosted version, but, as far as I can tell, it was not carried over.

    #596072

    timethief
    Member

    As the post number setting here > Settings > Reading is failing to work and as Volunteers cannot help you with this > please report this directly to Staff > http://en.support.wordpress.com/contact/

    #596084

    joliver
    Member

    Update:

    Support has fixed the issue that makes all past posts appear as featured. Joy! However, standard posts will not show up on your home page unless they are stickied. I fixed this by going to the posts section on my control panel and bulk editing all of my posts so that they appear as stickied. I then utilized the Settings>Reader to control how many posts appeared on my home page. And, of course, you can still control whether the posts show as summarized or full in the Theme Options.

    #596085

    joliver
    Member

    Actually, ignore that.

    #596093

    aadduk
    Member

    I have only one post showing on my front page….

    Is it a bug? Should I just wait and see if they fix it?

    #596096

    timethief
    Member

    If you read the other forum threads on this issue you will find that Staff have been notified of the issue. It’s Saturday and they will not be available until Monday.

    #596100

    thefoxchild
    Member

    I had contacted support about this same issue and was told that the way this theme is designed to work is that only the one most recent, standard post shows up automatically. To get any other posts to show, you must sticky them. No other posts/recent posts will show without you manually changing the settings for each post. So according to the support staff, the theme is functioning as intended.

    #596101

    timethief
    Member

    @thefoxchild
    Thank you so much for sharing that information. :) I will bookmark it and share it with any other members who post on this issue.

    #596145

    hi there. how do you sticky the other posts so they also show up as featured on the home page? and also how come the latest story does not appear on the home page with an image?

    #596146

    airodyssey
    Member

    @techmumonline: Here’s how to make a post sticky…
    http://en.support.wordpress.com/posts/post-visibility/#sticky-posts

    And did you set up a “featured image” for that particular post?
    http://en.support.wordpress.com/featured-images/#setting-a-featured-image

    #596148

    aadduk
    Member

    I had trouble with images too. I found that you have to go into Theme Options and in General tick ‘Check this if you wan tto show full content on home page’. Also I found that, certainly for video, you have to make sure the image is the right size. I did it by trial and error. Go into Settings the Media and you can adjust the size until it fits.

    I am still trying to get to grips with stickying posts.

    #596150

    aadduk
    Member

    It seems really odd that, after all the time and effort that has gone into making blogging software, someone would come along and limit WordPress to only showing one post automatically. A web page with only one post on it isn’t really a blog, is it? It is a, hmmm, what the phrase, oh yes, web page…

    It must be some sort of bug – I had all my posts showing up yesterday morning (my time). It is hard to credit they won’t give you the option of choosing how many you wan tto show.

    #596165

    Love the theme, but really hate the way the “featured posts” look on the blog. So, when I do sticky each post, they show up, but look awful. I wish the theme had a way to show the last 5-10 [or however many] most recent posts in the “normal” style, as opposed to the featured style.

    #596166

    thanks. will check that out. have to agree with @femmepastiche – would be great if there was a way to show the last 5 to 10 most recent posts.

    there’s certainly some wierd things happening with the theme which don’t happen when not using wordpress.com

    #596168

    hi there. my only concern, is if you make every post as “sticky”, how will it know as to how many to show on the home page?

    Would be great to have a way so that your lastest posts show up.

    also, how do you make the latest entry show on the home page with a photo. i can show the featured posts with a a photo, but the latest one doesn’t manage to show with photo.

The topic ‘The Morning After – Limit Featured Posts’ is closed to new replies.