The morning after theme- more problems

  • Author
  • #1059580


    I’ve had quite a few incidents, when the themes I was using just went all over the place. I generally change them, but I really want to keep my current one. Basically it says that my latest post is the first post that is not sticky in the list, rather than my actual latest post (which is featured, and sticky, but below a post from the beginning of the year). Help? Please.

    The blog I need help with is



    This is a highly customizable them. I strongly recommend reading this article on the theme and how it it is designed


    I know all those things, and it took me ages to get to the point where I knew how everything worked, and to customise it. I have been posting just fine until this evening when it seems to have gone bananas. I just wrote a new post, made it sticky, and then the trouble happened. I don’t understand why wordpress/the theme would say my latest post is from January 1st rather than November the 1st anyway? It doesn’t make sense. Also the big post at the beginning of the page is not even sticky in settings, how did it end up there I’m wondering?



    Maybe Themes Staff are improving the theme (tinkering and fiddling). I’ll flag this thread so we get a Staff response about what is going on.




    @almondsasdiamonds: The featured post on your home page for The Morning After is coded in the following manner:

    // Display the latest post, ignoring Sticky posts and Aside posts

    This means that all sticky posts and asides will be ignored, which is what’s causing the confusion. “CIM launches its Peace Ambassadors programme” is your latest non-Sticky post, and everything else in your Dashboard that comes after that post is sticky, which is why you’re seeing that particular post at the top of your home page. Hope that helps.


    Right, so does anyone know how to change this back to how it used to be? I’ve looked everywhere, I don’t know what to do with it.

    And was it something I did, or did it just randomly change? Sorry for asking all the silly questions, I’m a bit stuck.



    This is actually how the theme has always operated, it hasn’t been changed.


    Uhm, for a few months I’ve had my latest post as the actual latest published post.

    It has only started to show the latest post as the first post that is not sticky last night. I don’t understand why, and it’s really frustrating. If someone can tell me how to go back to what I used to have before last night, please help. I don’t want to have to change the theme again.



    Nothing changed with the theme recently, and this behavior has never been altered.

    What happened is that you are making your most recent posts Sticky, so they are ignored by the Latest posts section. As Philip mentioned above, this is how the theme is designed.

    If you want your latest post to appear there, it can’t be a Sticky post.


    Thank you so much! Makes perfect sense now.



    You’re welcome!

The topic ‘The morning after theme- more problems’ is closed to new replies.