Need help? Check out our Support site, then


The stats doesn't show real views

  1. The stats on wordpress.com doesn't show the views that I get, especially from the search engines as Google, whereas I am on the first page of this one.

    Even after I tried to connect on my website on google, the stats on wordpress.com doesn't change, and always show "0 view". What is the problem?

    I precise that I had already got views before (up to 1500 visitors per day), then sudenly from a day to another, it goes to 0 visitors. Help me, please !! :'(

    The blog I need help with is tutopipstycoon.com.

  2. Please read
    https://en.support.wordpress.com/stats/#views-and-visitors
    https://en.support.wordpress.com/stats/#search-engine-terms

    Additional information
    Our stats are not real time stats and take time to update. There are frequent fluctuations that most do not notice because we aren't watching the process. For details see here http://en.support.wordpress.com/stats/ and here https://en.support.wordpress.com/stats/#views-and-visitors and note the views and viewers take hours to update.

    Our stats are page view stats. But please do not assume that everyone who clicks a follow, like, share, reblog or comment link actually reads the post on your blog because odds are they may not.

    Follow, like, share, reblog or comment clicks are not page views. In fact, follows, likes, shares, comments and reblogs are completely misleading when you are talking about page view stats.

    Your followers and anyone with a WordPress.com/Gravatar account who is logged into WordPress.com can "follow" your blog, "like", "share" and "reblog" your posts and "comment" in several locations such as the Reader, without ever clicking into your blog and creating a single page view stat. Subscribers control how frequently they receive your posts (instantly, daily, weekly) and can comment without clicking into the blog.

    Logged in visitors using a mobile can read the full post without creating a page view stat. http://en.forums.wordpress.com/topic/wordpresscom-reader-show-full-text?replies=31#post-1373606

    You can control the length of the entry sent out on your RSS feed here Dashboard > Settings > Reading. Choose the "summary" setting for your RSS feed rather than to "full text". That will compel followers who are not using mobiles to click into the blog to read the full post which will create a page view stat.

Topic Closed

This topic has been closed to new replies.

About this Topic