Theme Header, image not showing up

  • Author
    Posts
  • #887632

    babdua
    Member

    Hi all,

    I’m trying to add a custom header image to the twenty eleven theme. I tried a 1000×288 as jpeg. After seeing strange results I tried png with the oddities remaining the same.

    Here’s what I did:

    * create an image with 1000×288
    * upload at theme > design > header

    first oddity:

    * I get asked to crop and publish the image, despite the help article (http://en.support.wordpress.com/themes/custom-header-image/) stating that, if the uploaded image has the exact size (which is the case here) I should not get asked to crop the image.

    second oddity:

    * when I check my blog I can see the image for 2 minutes or so, but then it is gone. In chrome I see a broken image (http://cl.ly/0B1x1k0t2B0A1z3X0c3V) in firefox I don’t see any image at all. when I go to theme > design > header I still see the correct image

    What’s going on here? Can someone help me troubleshoot this problem?

    Cheers

    The blog I need help with is babdua.wordpress.com.

    #887898

    timethief
    Member

    Will you please post an active link sstarting with http:// to the blog you are experiencing this issue on?

    #887924

    babdua
    Member
    #887925

    I don’t usually have any problems at all. I change my header every few weeks and also use the individual post header using 2011, which I really like, partly for that function.

    http://roughseasinthemed.wordpress.com

    The only time I have not been able to post a header is when they haven’t been big enough so sometimes I err slightly over 1000.

    What’s the file for your image?

    #887926

    Have you tried loading it as JPEG rather than PNG? which seems to be what your chrome link is saying…?

    #887927

    babdua
    Member

    Have you even read my initial post? It answers all your questions.

    #887928

    @babdua, can you go to media > library and find the header image and then get the URL of that image and post it here?

    #887930

    justpi
    Member
    #887932

    babdua
    Member

    Here’s the url http://babdua.files.wordpress.com/2012/05/wilhelm-wordpress-1000×2882.jpg

    So both oddities seem to be bugs on wordpress core software side? Hmm, rather flaky. Will this be only fixed when 3.4 is released? When is that due? Very annoying, currently – and simply broken.

    #887933

    justpi
    Member

    Yes, they’re both bugs. I would suggest you switch to a different theme.

    #887934

    This all has to do I think with the “theme customizer” that is going to appear with the 3.4 upgrade when it hits here full-force.

    #887935

    raincoaster
    Member

    Oh. Joy.

    #887940

    The reason I asked about JPEG was because when I looked at the Chrome link, there was no reference to that.

    Incidentally I use Safari, but I’m sure that is irrelevant. I did however upload a new header just yesterday, so it must be a selective/random bug.

    #887942

    raincoaster
    Member

    Browser is ALWAYS relevant. I’d say 30% of issues in the forum can be traced to people with browser issues.

    #887944

    Safari hasn’t been an issue around here for about 2 years or so. It is solid and I use nothing else for working with wordpress either hosted here or self-hosted sites, so the issue is not with Safari.

    This is an issue with wordpress and with the twenty eleven theme.

    #887945

    babdua
    Member

    thesacredpath is absolutely correct. check in chromium and firefox and safari. all have problems with the image. wordpress is breaking things. would be great if the core devs would show up with a statement other than “we are investigating”. since that statement has been posted somewhere I think mid/late april already.

    #887946

    babdua
    Member

    FYI: hm, is someone working on this? Currently the image seems to show up correctly.

    #887963
    #887975

    babdua
    Member

    Yes, seems to work. Still asking me to crop despite having the correct image size in the first place.

The topic ‘Theme Header, image not showing up’ is closed to new replies.