Need help? Check out our Support site, then

Thickbox issues - new windows opening instead

  1. Hi there,

    Just trying to find a work-around solution for some issues I'm having with my online portfolio -

    I've used the thickbox class on every image and linked different groupings together so that the viewer can scroll between those gallery sets, and it works (last I checked) seamlessly in Safari. However, in both IE and Firefox whenever I click an image, it begins to load the thickbox image as usual, but after a second or so, decides to either load that image in a seperate tab/window _as well as_ the thickbox alternative, or loads the image in the main site window and you have to navigate "back" to view the main page again.

    Needless to say, this has been a labourious exercise, having to manually link each image and address the changes that it makes to my layout in the HTML each time, in hindsight it would have been a wiser choice to stick to a wordpress.ORG and use the Lightbox plugin. If anyone can shed some light on my problem, I will forever be indebted to you.

    Many thanks in advance!

    - Chris

    The blog I need help with is

  2. The problem is because you've also specified a "target='_blank'" attribute in all your "a" tags. Remove it and that should fix this behavior.

  3. BTW, those illustrations are sick! *two thumbs way up*

  4. @Chris,
    Not to be thick or anything,
    how are you getting 'thickbox' to work?
    I've only been able to get it working by using the 'social vibe' widget.

  5. Thanks devblog, youre a legend! I'll make that change right away!

    1tess - I used the Vostok theme which keeps its sidebar beneath your main body. It splits the sidebar and widgets down the middle into two columns, and then those two columns are broken down into (I think) 4 sections. I randomly dragged and dropped the social vibe widget into the lowest row, and it disappeared off of my page, without removing the functionality of thickbox class. It's the only way I've found I could make it work.

  6. Brilliant on all points! Kudos!

  7. it worked! I think.. please check for me :P

  8. So enjoyed looking through your Galleries that I forgot to mention that in FF 3.5.9 the thickbox opened correctly on top of the page. I don't know if it did before you made the changes to the code but it does now.

  9. thank you Jennifer! appreciate it!

  10. now i've got some minor linking issues, please forgive the prevalent nude study that keeps on linking itself to "Self Portraits" - I promise that's not me! :P

  11. All fixed. many thanks again, guys! I appreciate your help and encouragement!

  12. Alright, looks like I spoke too soon. It only works without issue when I'm viewing the changes I've made to the page, and when I'm signed in. If I'm signed out, it does not behave the same. Any thoughts? I thought I got rid of all of the target=_blank's, but I'm not entirely convinced that this is the issue.. If I go to the image in Visual mode, I can edit it's properties, right up to target options (wherein I leave the tick box for "open image in new window" unticked), but if it doesn't have the target=_blank, it loads the image instead of the main page, and when you navigate back, it has the thickbox floating as it should.

  13. I took a glance and the source code and there are still some "target: _blank" lingering around. As soon as I can, I'll take a closer look and I'll get back to you.

    BTW, I'm using Firefox 3.6.3 (Mac) and it's working just fine... I smell a browser issue here.

  14. I've removed all the target:_blanks that I can see, though there may be one or two lingering, they always have a way of sneaking back. I'm more and more convinced that it isn't the issue, though. I've looked at it with Firefox, IE, and Safari, and the only time that it pops up the way it should is when I'm logged in. If I'm viewing anonymously, the images start to load in thickbox, but then load over the main page instead. My housemate's a computer programmer, and he poured over the source code and couldn't work out a solution, even though he's been doing it for 10+ years. We tried stuff like adding onclick:"return false;" to the links to stop it loading over the main site, and a few other parameters, he said the only real way he can see it working is to use javascript or something like that, but wordpress.COM strips it out straight away.

    When you say "it's working just fine", is it "when I click the images they load, then I click back to see the main page" or "when I click the images, they pop up because thickbox is working"?

    thanks for your patience!

  15. Yes, adding event attributes to tags get stripped by the software

    There are still some lingering like:

    <a class="thickbox" href="" target="_blank">
    <a class="thickbox" href="" target="_blank">

    However, is not just a browser issue as I thought. It's a cookie issue as well. I'll explain shortly.

    When I say "it's working just fine" I mean that thickbox is working. I should've add, though, that this is just in Fx.

    Now, I'm saying this is not just a browser issue but a cookie one as well because:

    a) I deleted all the cookies (therefore I wasn't logged in) in Fx and thickbox still worked.

    b) I opened your blog in Chrome (I wasn't logged in) and the images load (separately) but I had to click the back button to go back to your blog. I logged in and then thickbox worked. Then I deleted these cookies:

    wordpress_logged_in_ea9453593 :: domain:
    wordpress_ea9453593 :: path: /wp-content/plugins
    wordpress_ea9453593 :: path: /wp-admin
    wordpress_logged_in :: domain:
    wordpress_sec :: path: /wp-admin
    wordpress_sec :: path: /wp-content/plugins
    wordpress :: path: /wp-admin
    wordpress :: path: /wp-content/plugins

    And the images loaded separately again.

    Thickbox is loaded in the "header" section of the markup (even if you're not logged in) so it should work.

    I believe this should be brought to support's attention since, to me, this is a bug.

    Here's where you can contact them:

    I'd suggest that you point them to this thread so they can read what's going on and find a fix to this odd behavior.

    BTW, I really like the "sky fishermen" series. Very cool.

  16. thanks again for your help, devblog! I'll bring it to supports attention as you suggested, hopefully we can have a fix written for it soon. oh, and I'm glad you like my stuff! :D

  17. head/desk Just call me Johnny-come-lately.

    At this point I can only hang around and confirm your and devblog's assessment. :) When I logged out of WP (didn't even clear browser cookies) the images started to load in the thickbox and then shot off to their own browser window. Again FF 3.5.9.

  18. I received a message from Support, and they suggested a few links to people troubleshooting thickbox, but some I'd already exhausted in prior searches, and others weren't helpful to my specific issue. doesn't look like there's any fix or support offered in this case, since it isn't an official feature of .COM blogs. might have to shift my domain over to another provider and build a site from scratch.

  19. Thank you all for your kind support in the matter. I've bitten the bullet and decided to call it a day with the account and use another provider thats a little more image friendly. Maybe I'll return one day if the blogging bug bites ;)

Topic Closed

This topic has been closed to new replies.

About this Topic