This feature requires iframe support

  • Author
    Posts
  • #47403

    Hi All:

    This is a question about posting an image to my blog. Sorry! I get the impression that questions on this topic have been asked many times. I am very impressed with Dr. Mike’s post on the topic of uploading a picture to your WP.com space.

    I have tried to follow his directions carefully. But, I get stuck at this step:

    “- Under the “Post” text area, you will see another form with the labels “Upload”, “Browse”, and “Browse All.” This is what we’re going to use for uploading your picture to your webspace.”

    I don’t see the form with labels “upload,” “browse,” and “browse all.” Instead I see a message that says “this feature requires iframe support.”

    I looked up “iframe” on google, but the articles are written at a technical level beyond me.

    I am accessing my wordpress.com blog from Firefox 2.0.0.1.

    Thanks

    #47526

    drmike
    Member

    Actually that’s the old FAQ and is out of date. (You are lucky though that I fixed teh broken pics in it this morning.) The updated one is here.

    iframes should work with firfox. Not sure why you’re getting that error though. Hopefully someone will pop up with an answer.

    edit: Link fixed in teh sticky. I could have sworn that I did that months ago.

    #47529

    are you running the adblock extension?

    #47553

    Hi sunburntka:

    I might be running adblock extension. How do I find out? How do I turn it off?

    #47555

    devblog
    Member

    Is not the Adblock extension. I made that test and when you block the iframe it will make the whole thing disappear. Not even the “This feature requires iframe support” came up.

    Besides, because of localfoodsconnection’s question, I can tell that he doesn’t haven’t it installed… but just in case, click on Tools > Extensions. A small window will pop-up. Look for the Adblock extension (it’s called Adblock or Adblock Plus) if it’s there, right click on it and click on “Disable”. For this change to take effect, you need to restart the browser.

    EDIT:
    Sorry, the instructions I gave you were for Firefox 1.5. For version 2.0 click on Tools > Add-ons and when the small window pops-up, make sure the Extensions ‘tab’ is selected. Then proceed with the rest of what I suggested.

    #47558

    ufcdaily
    Member

    I had the same exact problem, and I had luck doing this (and I use Firefox).

    Make sure you save your work (“Save and Continue Editing”), and then hit Ctrl+F5. If the upload box still isn’t there, try it again.

    Sometimes I have to do that 3-4 times, but it always shows up eventually.

    #47562

    jaroche
    Member

    I guess the problem is a slow Intenet connection, when I had a very slow access link have troubles with frames.

    #47575

    Hi everyone. thank you so much for your ideas! I had been having problems with several other websites. As I thought about sunburnt’s suggestion of adblock extension – well anyway….

    The problem was with McAfee Security! I turned off its adblocker, and I added wordpress.com to it’s list of accepted sites. Now the upload frame appears in my “write” window!

    Happy, happy resolution to a long standing problem!

    #47596

    timethief
    Member

    YAY! I love happy endings. Thanks to those who helped solve this problem. :) yay! kamel ;)

    #47601

    jaroche
    Member

    Happy bloggin’ ;)

    #47602

    The problem was with McAfee Security! I turned off its adblocker, and I added wordpress.com to it’s list of accepted sites.

    thanks so much for letting us know, i’m sure it will help others in the future!

    #48043

    scrappydo
    Member

    Hi – i have the same iframe message coming up. What will happen if I turn off the ad blocker in Macafee? I don’t want a whole bunch of ads coming at me which is why I presume it is turned off to start with. I have added WordPress to the accepted sites but still get teh iframe message. Can anyone help -in simple terms (sorry – true novice here!) – and advise what else might be the problem. BTW, I’m running ie7 if that is important…
    Cheers!

    #48044

    drmike
    Member

    Just turn it off while you’re here and turn it back on when you leave.

    A number of adverts are delivered via iframes although to complete turn off iframes is I think overkill. This is just Macafee hitting yet another false positive.

    #48045

    scrappydo
    Member

    OK – thanks, I’ll give that a go. You guys are sure kept busy round here!

    #48055

    vinegargirl
    Member

    After much searching and frustration I can finally post pix. Thankyou!!!

    #48056

    drmike
    Member

    This should be in the FAQ IMO.

    Oh, Mark….

    #48057

    kerbo
    Member

    Hi, almost total novice here.
    This forum thread seems to answer my questions exactly except… I am getting the same message re iframes AND I run McAffees, but I cannot seem to find the adblocker bit, nor the place to allow wordpress. I am hosting wp on my own site. Any dummies instructions would be appreciated.
    Thanks,
    Kerri

    #48058

    raincoaster
    Member

    You need to be over at WordPress.org; this support forum is for WordPress.com hosted blogs and we’re running very different software here. I don’t think we can help you. Our answers are going to be very different and inapplicable to you.

    #48059

    drmike
    Member

    But just for reference, here’s a workaround.

    I saved this thread for next time. :)

    edit: Well, i thought I had. Let’s try that again…

    #48060

    johnbrowne
    Member

    I have the same problem: I cannot upload YouTube videos, as it says I need iframe support. I have no idea what this means.

    I use Firefox, and it works on my computer at university, but not at home…?

The topic ‘This feature requires iframe support’ is closed to new replies.