Too many comments leads to "Connection Reset"

  • Author
    Posts
  • #653119

    I have a problem which I think is down to the new comment box that was added a few weeks ago (unfortunately). I and most of my readers have been complaining that after making several comments, they get “Connection Reset” and cannot get back onto the website.

    I discovered that deleting cookies (that old WP solution to all ills) made it possible to get back on.

    I now think I know what the problem is…..

    With the new comment box, the entire comment is saved in a cookie. A cookie is saved for each post that is commented on. Eventually some limit or other is reached, resulting in a “Connection Reset”. If just one or two of these “comment cookies” are deleted, then a connection can be re-established.

    Does this make sense? Is this another bug? Do I have any way to either increase the cookie limit or to inhibit the saving of these particular cookies (unlikely)?

    The blog I need help with is thomasmacsblog.wordpress.com.

    #653217

    timethief
    Member

    We Volunteers answering support questions cannot answer this one for you. Only Staff can. http://en.support.wordpress.com/contact/

    #653218

    timethief
    Member

    You can check status here > http://status.automattic.com/9931/135469/WordPress.com There doesn’t seem to be any issue connected to yours there. However, I visited the blog and I was astonished at how many pages you have and how many video embeds are in each one. I also noted that you have many video embeds on your front page and I’m wondering if there could be any interference from any of them.

    #653426

    Sorry @timethief – the blog associated with this username is just a test one (in fact was an attempt to back-up my “proper” blog). The username associated with my proper blog cannot be used on the forums. This is an on-going propnlem that support seem to be ignoring, in that I can post comments on this forum but they are (literally) invisible to everyone but myself!

    The issue is that when you make a comment, the contents are stored in a cookie. Each page you comment on creates a new cookie (called comment-<postid>).

    Eventually the sum contents of all these cookies are sufficient to cause a connection reset which blocks access to the blog until some of the cookies are deleted.

    The fault started occurring when this new comment box was introduced. I cannot see any reason why comments are stored in cookies….

    #653427

    Just as a point of interest @timethief, if I made sufficient lengthy comments on your blog (or any other WordPress one come to that) the same thing would happen. In fact I wouldn’t even have to submit the comments!

    The cookie is created when the reply box is typed into – not when the comment is submitted.

    Try it yourself and you will see. (I’m using Firefox 4)

    #653435

    raincoaster
    Member

    It’s probably a built-in anti-spam measure. Report it to staff from any of your dashboards and maybe they’ll adjust it or give you the option to opt-out. Repeat commenters are the BEST!

    #653501

    I thought that at first until I realised it was the comment cookies. Its not looking for duplicate comments – its simply that there is a limit on total size of the cookie content.

    #653512

    raincoaster
    Member

    Hmm, well staff should know that too.

    #653550

    I have told them but, as usual, my information falls on deaf ears. :-(

    #653647

    Hurrah! Eventually staff told me that what I was seeing was theoretically possible and have now abandoned the idea of saving comments in cookies.

    You can now close this thread. Thank you to support.

    #653648

    mmadfan
    Member

    Maybe this means I and others will no longer have ghost comments and ghost replies showing up when I/we try to reply or comment? That would be great!

    You can mark the thread “resolved” in your initial post now, thomaspaulmac.

    #653649

    @mmadfan – that’s correct – no more ghost comments (as this was achieved via cookies).

The topic ‘Too many comments leads to "Connection Reset"’ is closed to new replies.