Too many posts on front page

  • Author
    Posts
  • #880911

    I’ve been told that my blog is really slow to load and upon checking it out I realized that the home page has around 15 posts on it and they aren’t even in chronological order. The top three posts are my latest posts, however, the ones below it are in random order. I’ve changed the settings under the “Reading” option to only display 3 posts and it didn’t do anything. Does anyone know how to fix this?

    The blog I need help with is cookingcollegechick.wordpress.com.

    #881009

    You’ve made all your posts sticky posts. You need to “unstick” them.

    Go to pages > all pages, click the box of top left of the list to select all the posts, select “edit” from the bulk actions pulldown and then click the “apply” button and deselect “sticky” and then click the “update” button.

    You may have more than that one page of posts set as sticky, so you might have to go through a bunch of them.

    Also, you are putting way too many images in each post for the front page. I would suggest using the read more tag in your posts to hide some of the images and then people can click on the “read more” link to see the full post with all the images.

    #881129

    adilger
    Member

    My problem is that I do not have the option “Blog pages show at most” at the Reading Settings. How can I get it or is their another option to limit the number of posts on the front page?

    #881170

    justpi
    Member

    The option is hidden because you’re using “infinite scrolling”. Go to Appearance > Widgets, drag a text widget to one of the footer areas, then go to Settings > Reading, disable infinite scrolling, set number of posts per page, save changes.

    #881171

    adilger
    Member

    Thank you very much, it worked.

The topic ‘Too many posts on front page’ is closed to new replies.