Top post widget in sidebar using photon servers

  • Author
    Posts
  • #1066925

    helmstone
    Member

    I believe the top posts widget uses the photon servers even though I have disabled photon. Some images show as missing.

    If I enable photon the same images are missing from the posts listing on the front page
    Blog url: http://redrocketrising.com

    The blog I need help with is redrocketrising.com.

    #1067136

    kardotim
    Member

    Can you please try clearing out your cache?

    Do you also encounter this issue in a different browser? for example Firefox or Google Chrome?

    #1067139

    helmstone
    Member

    Clearing cache no difference. Chrome on laptop, IE on a desktop.

    I just don’t understand why the image links in this widget wander off to the Photon servers when I have not enabled it!

    #1067140

    kardotim
    Member

    What’s your blog URL? I can’t seem to open redrocketrising.com

    #1067141

    helmstone
    Member

    It was unavailable for a short while (hosting provider comms problem) It is there now: Red Rocket Rising

    #1067142

    kardotim
    Member

    Have you tried removing the Widget and adding it again? Also try to completely disable and enable Jetpack.

    Otherwise please give it a little while since images are still cached. I can see them perfectly fine though.

    #1067143

    helmstone
    Member

    About 90% of the images work, just occasionally they fail. I will try the re-install of the widget and Jetpack and let you know

    #1067144

    helmstone
    Member

    Re-installing the widget made no difference. If I re-install Jetpack will I lose my stats?

    #1067145

    kardotim
    Member

    You won’t lose stats as they are stored on WordPress.com.

    #1067146

    helmstone
    Member

    I tried a different blog and get the same problem. This blog is much simpler:

    The Craft of Words

    #1067152

    mdawaffe
    Staff

    Even when the photon module is off, the use of photon URLs in that Widget is intentional; we use them so that the widget’s images are formatted consistently with the correct size.

    That said, we’re always looking for feedback. Is the use of photon URLs in that widget undesirable for you? If so, why?

    Thanks for getting in touch.

    #1067157

    helmstone
    Member

    The problem I had was some images weren’t on one of the image servers so I was getting missing images. That’s how I noticed the difference.

    I have turned photon back on. If you search for ‘train’ in the box marked data retrieval the picture doesn’t show in the post listing but does on the actual post. Clearly that is a problem!

    #1067158

    mdawaffe
    Staff

    So you host your images from multiple servers, and some of your servers don’t have all the images?

    If that’s the case, then some of your visitors won’t see the image no matter the state of the Photon module or the behavior of the Top Posts and Pages widget.

    It’s not clear to me what Jetpack should do differently. Do you have a suggestion?

    PS: The fact that you can see the image on the post’s permalink makes me thing there’s a bug in the Photon module: it’s not catching all the images. Is that image part of the post content (what you see in the post editor), or is it output directly from one of your theme’s template files?

    #1067159

    helmstone
    Member

    The image is in the post. All my images are local (apart from mistakes on import).

    I think it is the photon module not catching everything. It may be something I am doing but I can’t see what. My theme pulls the first image as the lead if there is no featured image.

    I can’t spot a pattern in the few that don’t work!

    #1067162

    @helmstone, when problems like this happen, the best thing to do is to post specific examples. I looked up your http://thecraftofwords.com/ site, and I found an example of a broken image from the Top Posts widget:

    * Photon URL: http://i2.wp.com/thecraftofwords.com/wp-content/uploads/2012/11/file000699643775.jpg?resize=40%2C40
    * Original Image URL: http://thecraftofwords.com/wp-content/uploads/2012/11/file000699643775.jpg

    In contrast, I see a separate image in the Top Posts widget that is working as expected:

    * Photon URL: http://i1.wp.com/thecraftofwords.com/wp-content/uploads/2012/11/Pic.png?resize=40%2C40
    * Original Image URL: http://thecraftofwords.com/wp-content/uploads/2012/11/Pic.png

    I will see what I can find out about why that first image isn’t working.

    Regarding your question about turning Photon off completely, the developers are discussing an update that would make it so the Top Posts widget will not use Photon unless the Photon module itself is enabled in your Jetpack settings. If they decide to go ahead with that change, you will see it start working in a future Jetpack update.

    #1067163

    helmstone
    Member

    Thanks for the follow up. I suppose really the ‘Top Posts using photon’ is a diversion from the real problem of ‘Photon doesn’t cache all images’!

    I will endeavour to link reports up better in future!

    #1067165

    I’ve found out a little more information. The Top Posts widget, and possibly other widgets may use the Photon API separate from the Photon module in Jetpack. In those cases, you do not have the option to turn it off. If the images aren’t loading, it’s possibly a bug or something wrong with how the images get served. In your case, the images are very slow loading (more than 10 seconds) between your server and the Photon servers and that’s why the images look broken. We’re looking into if there’s anything we can do from our side to speed things up or not. I’ll post back as soon as I hear back any additional information.

The topic ‘Top post widget in sidebar using photon servers’ is closed to new replies.