Top Rated Widget (Comments) shows only 3 comments?

  • Author
    Posts
  • #1564927

    nbakic
    Member

    Top Rated Widget for comments shows only top 3 comments for each of All, Today, This Week, This Month though I set it on 20. Any idea how to get around?

    The blog I need help with is trzistakapitala.wordpress.com.

    #1565019

    timethief
    Member

    Have you tried un-installing and then re-installing the widget?
    http://en.support.wordpress.com/widgets/top-rated-widget/

    #1565023

    raincoaster
    Member

    How many comments on your blog have been Liked?

    #1565024

    nbakic
    Member

    Thank you! Yes, I tried it.

    #1565027

    timethief
    Member

    Did reinstalling the widget work for you or not? If it did not work then type modlook into the sidebar of this thread for Staff assistance. Then subscribe to the thread so you are notified when they respond and please be patient while waiting.

    #1565028

    nbakic
    Member

    50+. I turned it on just today.

    #1565030

    nbakic
    Member

    50+. I turned it on just today.

    #1565034

    nbakic
    Member

    @timethief It behaves erratically. For example, I have marked only ratings on comments to be shown, and it still shows top-rated posts and pages, too.

    What I chose for the number of top-rated items seems not to matter much; for example now it is set to 15 – it shows 3.

    The most curious part is that it really behaves erratically, changing betweed all items (posts, pages, comments) and comments only, without my intervention, it changes within minutes.

    Should I type ‘modlook’ into the ‘tags’ field, I do not see any other place in the sidebar?

    #1565052

    kardotim
    Member

    Do you still encounter this issue? I’ve just checked and it looks fine on my end. Do you also encounter this issue in a different browser? for example Firefox or Internet Explorer?

    Thank you.

    #1565061

    nbakic
    Member

    Thank you kardotim. The issue is still there. It looks all the same in Chrome and IE. Sometimes, but rarely, it looks almost OK, but in general far from it. E.g. it shows ‘top rated’ for posts and pages, though I did not mark it, and for comments it shows some random number of them (3,5 …) though it is currently set to 15.

    #1565062

    kardotim
    Member

    You need to have ratings enabled on your blog for this feature to work.

    You can enable this at https://trzistakapitala.wordpress.com/wp-admin/options-general.php?page=ratings&action=options&rating=posts. Also please follow the steps in this guide on how to set this up http://en.support.wordpress.com/ratings/

    #1565063

    nbakic
    Member

    Thank you! But this is NOT a solution. The issue is, I want only comments to be be displayed, and not posts. Ratings and posts are *disabled* (there is some residuum from some time before when it was enabled).

    So, in my widget, I have marked only top-rated comments to be displayed, and it still shows posts and pages, too, and shows some random number of comments, though there are many rated comments by my readers (I suppose it is by far the most popular blog running on WordPress in Croatia).

    #1565066

    kardotim
    Member

    I’ve just re-set the widget and it only shows the comment section now. A developer will check why the widget is showing 3 top rated comments instead of 15.

    I’ll contact you once we know more. Thank you for your patience.

    #1565067

    nbakic
    Member

    @kardotim The problem persists :(

    #1565068

    kardotim
    Member

    Things are slightly delayed due to the holidays. It’s on the developer’s list to fix. I’ll keep you updated.

    Thank you and happy new year.

    #1565069

    kardotim
    Member

    Thank you for your patience.

    The issue is caused by the fact that there are multiple Top Rated widgets set on your blog. Our developer deployed a fix that resolves the issue if you have just one Top Rated widget set. The outstanding issue is still on the todo list and will take a longer time to fix.

    #1565070

    nbakic
    Member

    Thank you!
    It seems it works now.

    #1565071

    kardotim
    Member

    Cheers. Please let us know if you need any further assistance!

The topic ‘Top Rated Widget (Comments) shows only 3 comments?’ is closed to new replies.