Need help? Check out our Support site, then

transferring wordpress custom domain to squarespace

  1. Hello I need help transferring my wordpress custom domain to squarespace. All of the information I have found has pointed me to changing the nameserver but squarespace specifically requests a CNAME which I don't believe to be possible in the DNS manager.

    The blog I need help with is

  2. You can do CNAME here as explained here: .

    <soapbox on>
    For the life of me, I can't believe they don't do it with nameserver instead.
    </soapbox off>

  3. I also need to change my A record for this, and WordPress says the formula is this: "A<subdomain><IP>" but what do I put in the "<subdomain>" field? Squarespace says to put "@" but WordPress is saying that's incorrect.

  4. Are they requiring an A Record too, or just a CNAME?

    If they're requiring an A Record, what are the A Record and CNAME values that they need?

  5. Squarespace requires both a CNAME and an A Record. This is how squarespace says to do it:

    CNAME <subdomain> <host>.
    A <subdomain> <IP>

    More specifically:

    CNAME www
    A @

    But WordPress won't accept that, it says the A Record is incorrect.

  6. I have set your domain as requested.

    Please let us know if you need any further assistance!

  7. You mean you already created the CNAME and A Record for me? Or do I still need to go in and do it?

  8. Yes, I have taken care of that for you.

  9. wow, thank you so much!

  10. You're welcome!

  11. For some reason, it's still not working. Squarespace says the CNAME and A Record are still the old ones. I've tried to create new ones again in the DNS Manager but am running into the same problem where WordPress says it's incorrect.

  12. They're definitely reported as what you said two days ago.

    Would you please ask what they're seeing and what they should be?

  13. They said they viewed my A records and there are several A records associated with my domain (which may be causing an issue) but none that are pointing to the correct location. They sent me a screenshot, so I too am able to see that they are all pointing to a different IP address. I need both the CNAME and the A Record to point to the following values:

    CNAME www
    A @

    The Squarespace support team suggested I direct you to the following site so that you can run a search on my domain and see the settings that are not registering:

    Thanks so much for your help!

  14. Right, I see it just fine there too, as well as where I check primarily at which shows your A Record as globally.

    However, I do see something wrong with and I'm trying to fix that now. It may take a few hours for the change to take affect.

  15. Are you checking for Because when I check that domain at both those sites it shows lots of A Records all with completely different IP address.

    Oh! I think you're checking/ changing the person's domain who asked a question before I did:! My domain is

  16. Oh goodness. This is why we ask everyone to please create their own support requests rather than joining a thread that's over a month old.

    I'll try to fix the OP's domain first, then I'll get back to yours.

  17. Ok, your domain is set, but it may take a few hours for the change to take place.

  18. Sorry, I was unaware! Thank you so much for your help! It seems to be working now. Really appreciate it!

  19. Ok one last question: it works when you go to but not there a way of changing this?

  20. Hm, it's set exactly as Squarespace said to set it.

    Now that we've adjust the right domain, would you please check with them?

  21. They said it means the CNAME is incorrectly mapped. They asked me to share this guide with you on how they need it:

    Thank you!

  22. That's exactly how we have it set, CNAME is set to for www.

    This particular CNAME rule only affects the www sub-domain, CNAME doesn't affect the root (non-www) domain.

    The A record affects the root domain, and that's also set as instructed.

  23. If it's been changed within the last 72 hours that could be the problem, but if that's not the case they tell me it's a DNS issue. I'm sorry, I'm not sure what I can do to help but I'd really appreciate your help getting this issue solved. Again, it's for

    Thank you!

  24. We made a tiny tweak on our end to compensate, but it may take a few hours for the change to be active.

Topic Closed

This topic has been closed to new replies.

About this Topic