Translations are not applied

  • Author
    Posts
  • #422356

    irdb
    Member

    It seems that new translations are not applied even after validation by a validator.
    I just want to know if there are additional steps to be passed after validation or not. How long should I wait?

    Here is an example:

    Term: Topics with no tags

    New translation: مباحث بدون پاسخ

    Status:
    current

    Date added:
    2009-09-23 18:43:31 GMT

    but I still can see the old translation in the Persian forums. (I am also a validator and I have validated it myself)

    There are many other examples.

    Anyone else experiencing the same? Is this usual?

    The blog I need help with is dalbablog.wordpress.com.

    #422568

    keymangreek
    Member

    Noticed the same in polytonic greek

    #422572

    Sorry guys, still ironing some kinks, will start deploying on monday.

    #422631

    You should be all set. Could you check?

    Thanks.

    #422632

    irdb
    Member

    Not yet.
    I still can’t see new translations.

    #422633

    miladin
    Member

    More than day after updating, translations are not deployed for Serbian language. You should tell us how deploying works, is it manual or automatic and on what time periods it is done.

    #422637

    keymangreek
    Member

    New polytonic greek translations OK.

    #422646

    irdb
    Member

    The problem persist to exist here in Persian

    #422658

    Yes, we’ve noticed a problem deploying Persian and are looking into it. Thanks

    #422659

    miladin
    Member

    Please check Serbian too.

    #422660

    Serbian was deployed. Could you check? Thanks.

    #422666

    miladin
    Member

    Yes, it was, thank you. But I’ll repeat what I said in my previous message: you should tell us how deploying works, is it manual or automatic and on what time periods it is done.

    #422679

    ravidreams
    Member

    Yes, I also have the same question as miladin. If you could explain the deploying process it would be helpful. If it is peridocally and automatically deployed that would be great.

    earlier we used to complete the translation and post a request here. Then one of the developers will commit.

    #422680

    @ravidreams: there was never a process in place where users could request translation deploys, maybe you’re confusing this with .org rosetta deploys. Deploys were always manual and never had a preset periodicity. They simply happened when a critical amount of new translated strings was reached, which is around 200.

    The deploy process hasn’t changed at all, it’s the same. The only thing that’s changed is the visibility of the platform, which makes it now too easy to cede to the temptation of translating and validating a few strings and then awaiting an immediate deploy.

    To keep it all in context, deploys affect 8 million + blogs, it is simply not feasible or desirable for the stability of everybody’s blog to have the process run at much shorter intervals.

    #422681

    irdb
    Member

    New Persian translations are not deployed yet!
    So please don’t mark this topic as resolved.

    #422682

    You are free to change the status… :)

    #422683

    @irdb

    Should be ok now. I had to reject this string as it was causing trouble.

    #422684

    irdb
    Member

    Thanks Zé!

    It seems to be working now, however I didn’t understand what was wrong with that translation. And I don’t dare to use it again :)

    Thanks agian

    #422685

    The deploy was stopping at this error:

    msgid and msgstr entries do not both begin with \n

    I’d try it first in PoEdit (should validate in the exact same way)

    #422686

    miladin
    Member

    They simply happened when a critical amount of new translated strings was reached, which is around 200.

    To keep it all in context, deploys affect 8 million + blogs, it is simply not feasible or desirable for the stability of everybody’s blog to have the process run at much shorter intervals.

    I don’t understand definition of “200 new translated strings”. Is this per locale or new strings that appear in POT?

The topic ‘Translations are not applied’ is closed to new replies.