Need help? Check out our Support site, then

Trouble finding users to add as authors

  1. I am trying to set up a group blog. Several of the people who I want as authors to the blog have signed up to WordPress, however when I search for them either by user name or email address, I'm told they don't exist. I've sent them invitations but when they try to accept, the system tells them that they are already members.

    Has anyone else had this problem and, if so, how was it resolved?

  2. Are you sure you've got the correct usernames and/ email addresses that they signed up with? I know it sounds silly but that was the issue the last half dozen times this has come up.

  3. I've asked them to check this and they have assured me that I do. Obviously I can't be 100% certain but the fact that when I send an invitation the system won't let them register twice makes me 99% certain I've got the right address. Also, it's not just a problem with one user; it's a problem with several.

    With one of the users, it didn't work and it didn't work and it didn't work and then suddenly it did, despite the fact I didn't do anything differently (this was back in December). In that case I had the right user name all along; just the system was broken. The others it has never worked and hasn't since December when we first tried. They've even sent me their API key - not sure if this is useful though.

  4. As drmike indicated if they are trying to access the blog using a different email address than the one they registered with they will not be successful. I'm mentioning this only because most often when we hear about these issues that's what the problem is.

    This is then a feedback issue for staff to be notified of. When you send in a feedback please be sure to include all the information including the usernames of the additional authors and the email addresses they used when registering with wordpress.

  5. I have a somewhat similar problem. I've been added to a private blog as an author but somehow, I cannot post an entry there. All the other authors have been able to do it, except me.

    I got the Administrator to remove me and add me again, didn't work. I'm sure I've been added because the blog appears under my "Friend Surfer" tab in the dashboard but when I get to the blog, it doesn't appear in my blue menu 'new post' tab.

  6. It sounds like a sending a feedback to staff is required. Please include as much information as possible when you send it.

  7. Okay, I'll do that.

  8. jerms, I would check with the admin of the blog as you may not be assigned an access level that would give you the ability to make a post. Sounds like you're not.

    Here's the FAQ on the different roles that one can have with a blog.

    Hope this helps,

  9. drmike, this is the email I received from WP that I was added as an author. Wouldn't this be sufficient to allow me access to publish? I checked with the admin of the blog and I have been assigned an access level of an author, so can I assume that this is a technical error?


    You've been invited to the cure for island fever at as an author.

    If you don't care, just ignore this email. :)


  10. From the FAQs
    Is able to edit their posts, publish their posts and upload files. And they can delete their posts too.
    Provided the Administrator of the blog followed these instructions without success then volunteers on the forum, including drmike, can't help you beyond this point. So any further advice has to come from staff by sending in a feedback including the email you have and any other information you have.

  11. Alright, I have done that. Thanks.

  12. You're welcome and best wishes :)

  13. Hi, has anyone found a solution to this problem? I have contacted support and they've tried but, unfortunately, we still haven't been able to resolve it.

    Perhaps an enterprising user has found a workaround?

  14. Am I understanding correctly that, from their end it looks like they're authorized, but from yours it does not? Can they log in and post?

    Maybe delete them and re-enter them?

  15. Yeah. The blog I'm trying to post to already has several other authors able to post. It seems the bad luck is isolated, and it just happens to be on me.

    The administrator of that blog has already deleted me as an author and re-added me again, to no avail. Even upgrading me to an admin does nothing: when i try to access wp-admin on that blog I get redirected to the front page.

    Strange, no?

Topic Closed

This topic has been closed to new replies.

About this Topic