Trouble with adding photos to a page

  • Author
  • #304198


    I can upload the photos to my gallery (although I only need one photo right now). From my page, I choose Import Media – but on the “Add an Image” window that pops up, there is no button anywhere that says “add to page” or “publish this photo” – When I go to Gallery, there is no way to actually select that picture for import or publication on the page. (The only thing I can do is check the box next to the link “Show” or else Save All Changes.) So the picture doesn’t appear on my page.

    Any suggestions? This has got to be a very basic newbie question – I know it has to work – maybe it’s a browser issue? (I’m on Mac OSX Leopard running Firefox.)



    Moderator Emeritus

    You want to use the Media Library rather than the Gallery to insert an image into a post.


    Moderator Emeritus


    Thanks, 1tess. Yes, I have a wordpress.COM blog (not dot-org) and yes, I have tried to do this thru the Media Library – that’s where I’m stuck. My only clickable options on that screen are Search Media, Filter, Save All Changes or Show; when I hit Show, I choose an alignment and a thumbnail size and then Save Changes. But then I’m back to the main Media Library screen and – again – no option to say “preview” or “publish” – it feels unfinished. I just have to close that window to go back to my page and the photo is not there. No surprise, but I don’t know what else to do.

    I know there is something basic I’m missing here – would appreciate any help figuring it out. Thanks again. (BTW, I did search the FAQ and forums before posting but didn’t see anything about this.)



    Why don’t you just go to the individual page. And click on the add image icon. And then the popup will appear. There you click on the media library tab and there is where you find all your pictures uploaded. Or you can upload new pictures.


    @jbmitchell: Do you have a wp.COM blog? Where is “Import Media”?


    Moderator Emeritus


    Good point. I was assuming he/she was clicking on the little icon that is like a TV screen or a monitor on the editor page. But now I tried to check the address, and the name doesn’t seem to be .com. (thought I’d checked—blame it on multi-tasking).

    Maybe the missing step is once you click the media library, you must click on “show” associated with an image (not on the little icon-pic) to get to the time when you can insert the picture?


    Moderator Emeritus

    Never mind. I just read the post again. “show” was tried. I dunno.


    Moderator Emeritus

    I hit Show, I choose an alignment and a thumbnail size and then Save Changes.
    it should say “insert into post” not save changes?


    That’s the problem, Tess: what’s described is not what we’ve got in our dashboard. Unless I’m missing something, it’s either loose terminology or (more likely) not a blog.


    Moderator Emeritus

    I make too many assumptions sometimes.
    makes me want to keep my mouth shut.


    Yeah, I’d have to agree that ya make too many assumptions tess :P



    Okay, thanks for everyone’s comments – the name of my blog is: – I assumed that meant I had a blog?? If I am wrong about THIS, I obviously need to have my computer confiscated until I can figure out this technology stuff.

    I hit Show again from the Import/Media Library screen and now I do see “insert into post” – I am not going to kill any more brain cells trying to figure out why this was not apparent earlier – but I do appreciate everyone’s help. Maybe your support karma made it magically appear. Stranger things have happened.

    Thanks again.



    I am having the exact same newbie problem as jbmitchell, except that I don’t see “insert into post” on the Media Library page. Where should I be looking on the page, maybe I have a similar blind spot?



    I have the same problem!!!
    I attached the fotos but in the post is onlz written FOTO 1 and no image, nither gets blue and zou can klick it to see the foto…
    Im lost!
    the blog is
    the post thou is in CYRILIC so there You’ll be able to recognize only the signs of images… FOTO1. FOTO2, Foto3….. and so
    but the fotos are nowhere to see
    Im leaving the blog if I cant fix it, ei
    it s sad



    nothn sad
    Im just dum…

    The picture files are no image files! I guess the WP dosent recognize its a photo.
    But then still I dont get it? Why theres no link or smthing to the files I charged?

    So, Im not living the blog….

    may be some day I’ll have hours and hours to work on it
    may be


    @readspot: To have photos shown in a post, you’d better upload them in your blog, via the “Add an Image” button of the post editor.



    I had the identical problem and it drove me nuts. Before you click, “insert into post”, click on the “Post URL” button, THEN click “insert into post”. This worked for me!


    @ritterim: “File URL” rather than “Post URL”. File URL links to the full-size original alone, Post URL to the so-called attachment page (a useless extra step).

    And you only need to do that once: the uploader will then remember your preference.

The topic ‘Trouble with adding photos to a page’ is closed to new replies.