Need help? Check out our Support site, then

Trouble with getting domain pointed to Squarespace

  1. I was wondering if anyone could help me with getting my domain pointed to Squarespace. I've been trying to get this done on my own for the last few hours now, but after reading through the forums, most people had to have an admin point it for them.

    Any help would be greatly appreciated!

    The blog I need help with is

  2. If you’ve registered your domain through and now want it to point to a blog or website hosted elsewhere then you can do this by updating the nameservers.

    I'll tag this thread for Staff assistance too. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

  3. Thanks! I actually read those links that you've posted prior to me posting this thread, but I still couldn't get it to configure.

  4. Understood. Please be patient while waiting for Staff to help you.

  5. I've been seeing posts like these from WordPress support staff.

    Happiness Engineer
    Nov 6, 2013, 7:06 AM

    Hi there,

    The information you found on our support forums is out of date — since that post was made, Squarespace has changed their instructions for pointing domains to Squarespace. Our domain manager does not include a domain forwarding option like the one Squarespace currently recommends.

    I went ahead and entered the DNS records you need to point your domain to Squarespace. I also entered the records you need to keep your email working with your custom domain. (Please note it can take up to 72 hours for changes like this to take full effect.)

    Please let me know if I can help with anything else!"

  6. Hi Amanda,

    To point our domain to Squarespace, I will need your custom A record for your Squarespace blog. You cannot do this through adding a CNAME record. Once I have your A record, I can point your domain accordingly!



  7. @jeremeylduvall I'm also having the same problem, I wan't to forward my squarespace blog to my wordpress domain. is my new blog is my wordpress domain

    Thanks in advance.

  8. Hi @Doruk

    To do that, I will need your A record (from Squarespace). Then, I can point the domain to your Squarespace site.



  9. Helloy @jeremeylduvall

    How can I see that A record from squarespace ?

  10. Hi @Doruk,

    You may need to ask Squarespace for it. Sending something like this should do the trick:


    I'm trying to point my domain that is registered at to my Squarespace site. Could you please provide the A record for my Squarespace site? My Squarespace blog is..."

    Let me know if that doesn't work!



  11. Hey @jeremeylduvall

    I just got a reply from them so they told me that it is

    I'll be glad if you set my mail settings so I can continue using my gmail which is connected to my domain.

    Thanks in advance !

  12. Hi @Doruk,

    I've made the changes on our side. Please note, it can take up to 24 hours for the changes to take effect. If you're having trouble loading the correct page, can you try clearing your browser's cache and cookies? Instructions can be found here:

    Let me know if you're having trouble!



  13. Hey Jeremey, thanks for the reply. I reached out to Squarespace and this was their response.

    "We recommend you use the A Record '@' to point to ''"

  14. @jeremeylduvall thanks jeremey, it's all set now thanks to you !

    Take care,


  15. @Doruk Not a problem!

    @Amanda Yours should be good to go now as well. However, it can take up to 24 hours for the changes to take effect. You may want to try clearing your cache as described here:

  16. @jeremeylduvall hey jeremey, im just having one last problem

    I can send mail via my google linked mail, but I can't recieve any.

    Can you please help?

    Thanks in advance.

  17. @jeremeylduvall

    Delivery to the following recipient failed permanently:     [email redacted] details of permanent failure:Google tried to deliver your message, but it was rejected by the server for the recipient by [].The error that the other server returned was:550 5.1.1 <[email redacted]> recipient rejected----- Original message -----DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;; s=20120113;        h=mime-version:date:message-id:subject:from:to:content-type;        bh=yiXgoH2vZ3zQvrSd/zWI6/47InNHsGj4dNngqMuB858=;        b=q79eeFyA7NslbUKDf7Iotp7YqOWKRkiEraKMeb8S0ZZZBXFI27KITIMS1KfkgLiTrX         bTrpBTeEQ1eGQ4auRC0yK3eQQzXYlDIwXSdi3v/rpfSdSK1xXVEcoc6DqANgTYHwlRtH         4jdFGwK/w0udYsjzT1s10exZyLXfZbIV3wLWm7UZwI+ZE/o+TvF9y/Z92dUTn3vRc9mH         5co1+oZKcw8Y9Vrmrh5aLUjntBVjdXGlIKX2BPRRsptNRl49Jc+Ubnl2qWAg15zlcalM         PZcsm+Enl69mz/9P47J+3UeArOAOF0rvmaJsR7hlnMy+Ev80FfxfpSSxGnMMt3AFyfE/         t7VQ==MIME-Version: 1.0X-Received: by with SMTP id gg16mr16193338wic.32.1384768078745; Mon, 18 Nov 2013 01:47:58 -0800 (PST)Received: by with HTTP; Mon, 18 Nov 2013 01:47:58 -0800 (PST)Received: by with HTTP; Mon, 18 Nov 2013 01:47:58 -0800 (PST)Date: Mon, 18 Nov 2013 11:47:58 +0200Message-ID: <[email redacted]>Subject: aaaFrom: Doruk Yemenici <[email redacted]>To: [email redacted]-Type: multipart/alternative; boundary=001a11c223146e14bc04eb7071b3

    This is the error i get btw

  18. If I can get help from an active admin it would be very comforting.
    It's really urgent because I can't get any business mails,


  19. Hi @Doruk - Can you try again? I've added the custom DNS records to your domain manager. Please let me know if you're still having trouble!

  20. nope it didn't work @jeremey it instantly failed to recieve

    Delivery to the following recipient failed permanently:

    [email redacted]

    Technical details of permanent failure:
    Google tried to deliver your message, but it was rejected by the server for the recipient domain by [].

    The error that the other server returned was:
    550 #5.1.0 Address rejected.

    ----- Original message -----

    DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;; s=20120113;
    MIME-Version: 1.0
    X-Received: by with SMTP id lk5mr471722wjb.77.1384792623962;
    Mon, 18 Nov 2013 08:37:03 -0800 (PST)
    Received: by with HTTP; Mon, 18 Nov 2013 08:37:03 -0800 (PST)
    Date: Mon, 18 Nov 2013 18:37:03 +0200
    Message-ID: <[email redacted]>
    Subject: aaa
    From: Doruk Yemenici <[email redacted]>
    To: Doruk Yemenici <[email redacted]>
    Content-Type: multipart/alternative; boundary=089e01184e5670614504eb76286b

  21. @Doruk - Can you try one more time? I made some adjustments so everything should be in place correctly. Please note, it can take up to 24 hours for these changes to take effect.

  22. @jeremey it's not working, I will contact you later if it's still not working after 24 hours.

    Thanks !

  23. Hi @Doruk - Sounds good. I'll check back in if I don't hear from you. I've added the DNS records as you had them previously so it should start working.

  24. it's really weird that I can send mail but can't recieve.

    I'll inform you if anything changes,


  25. Hi @Doruk - any update with this? Are you still unable to receive email?

  26. hey @jeremey I just found what the problem is.

    Google tried to deliver your message, but it was rejected by the server for the recipient domain by [

    I realized that in my DNS settings, there were 2 more entries except the gmail MX values. was one of them and it had the value of 0.So after I removed those 2 entries, the mail started working just fine :)

  27. Hi @Doruk - Great! I'm glad we were able to get this working. Let me know if you need anything else!



Topic Closed

This topic has been closed to new replies.

About this Topic