Trouble with Publish and Update Buttons

  • Author
  • #1075116


    For the past few months I am frequently having trouble with the Publish and Update buttons not working/doing anything – ‘Save Draft’ seems to always work (and publishing from Quick Edit in the All Posts list works fine) and it appears that auto-save is working. Worth noting that in the past the Publish and Update did work without any problems and that very infrequently the buttons do work.

    Today I had problems in Firefox 15.0.1 and Chrome Version 23.0.1271.64 m – I did not clear the cache and cookies today, but in the past that troubleshooting step has not seemed to impact the problem. I am logged in with https. I am not aware of any major system/browser/plugin/setup changes between the time when the buttons worked/began not working, although certainly Windows updates and browser versions are constantly changing… I am usually connected via a mobile hotspot, but that has been true for many years now and I am not aware of having problems with my connection on other sites.

    At this point I work around problems by a combination of publishing from the ‘All Posts’ list and using the clipboard to – but this is less than ideal.

    Thanks for any help or suggestions!
    Charles Miles

    The blog I need help with is



    Do not log-in on the front page of Do not create posts here >!/post/

    Instead I recommend that you ONLY log-in directly you your own blog and ONLY create posts and edit them here > Dashboard > Posts > Add New

    If you are not running one of the browsers and versions listed at please try upgrading or switching first.

    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see >

    If you are, please do these four things:

    1. Try clearing your browser’s cache

    2. Make sure that you have third-party cookies enabled

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS:

    If you are not successful let us know which browser (and version of it) you’re using and post any error reports you get.



    Thanks for the reply. I followed all the instructions above and it is still not working, since you have a cut and paste answer to this question and saw a number of search returns from this issue (a number from you I believe) I assume it may be interesting (if not useful) to have some detailed information so I have included replies/notes to your suggestions/instructions below.

    However – so that it does not get lost in the long list of details below I think the most important detail that I figured out last night may be:

    If I try to use the Publish button with the “Visual” tab of the editor active it fails consistently (I believe actually 100% of the time). If I make the “Text” tab of the editor active it appears to succeed 100% of the time. (I thought Publish worked ‘sometimes’ – I am guessing the ‘sometimes’ were when I happened to be in the “Text” tab).


    I updated Firefox to version 17 as listed on

    I disabled all Add-ons and restarted

    I cleared the caches in Firefox

    Cleared existing cookies and confirmed that 3rd party cookies are enabled (and restarted Firefox for good measure)

    –Instead I recommend that you ONLY log-in directly you your own blog
    I actually do not know how to log directly into my blog at (am I just not seeing a link – weird…) – so I logged in via

    I have HTTPS: enabled per the link and confirmed a HTTPS: connection when on the dashboard.

    I went to All Posts and selected Add New

    I typed in a title and body text using the ‘Visual’ tab in the editor

    I hit Publish and nothing happened – I x2ed my blog to make sure the post had not been published (in another tab). I tried this several times just-in-case while typing this reply.

    I hit All Posts to go back to the post list and confirm the post did not publish – I get a dialog box with “This page is asking you to confirm that you want to leave – data you have entered may not be saved.” I hit Stay on Page and try Publish again – nothing changes or appears to work, I refresh my blog in the other tab to confirm it did not publish. I hit All Posts again this time choosing Leave Page.

    My All Posts list has my post in the list as a Draft (I delete the draft so I don’t confuse myself later…). I repeat the process of Adding New and Putting in a post, hitting publish to confirm I am not crazy – same results detailed above.

    Information that I think may be interesting:

    For – I believe years – this sequence worked without problem, and then became problematic ?within the last year (sorry I wish I had a date for easy comparison with svn history/browser version changes/etc… – I would say my estimate is +/- 6 months?).

    I can not remember any instance of Save Draft not working

    I can publish/schedule reliably from the Quick Edit Menu in All Posts (what I have been doing for awhile).

    I assume that this is some odd edge case – I also assume that if anyone ever wants to explore this that all my blog settings/information can be pulled out of the database so I will not speculate and list a lot of useless information.

    Hope that helps – please feel free to contact me here or via email with questions,
    Charles Miles
    (email redacted)

The topic ‘Trouble with Publish and Update Buttons’ is closed to new replies.