Need help? Check out our Support site, then

Trouble with site address

  1. Hi,

    I have a wordpress account that I registered a few years ago. I never did anything with my account after that. Recently, I've been wanting to start using wordpress, but did not like the URL that I registered earlier. I should have just created another blog but instead in Dashboard->My Blogs, under the blog address, there is a link to change address. I clicked on it and gave the new address I wanted.

    But now it seems like everything is messed up. I don't see the new address in my dashboard. It still shows the old address but the site with the new address is up. Whenever I try to add a new post, it gets added to the old address but not the new address.

    It would be great if someone can shed some light into this. How can I get rid of the old address completely? How can I add post to the new address.


    The blog I need help with is

  2. What are the URLs please stating with http://
    And which username account registered which URL?

    You must be logged in under the exact same username account that registered any blog to access it.

    Clicking this link should display all your blogs registered under the same username, including the hidden ones:

    If you do not see the blog here then
    follow this guide >

    If you have lost your log-in information you can visit

  3. This is the one I registered couple of years ago

    and this is the new one I changed to

    Both of these are up. However in my admin account I just see and not

    and there is one more thing. I also changed my username today. Not sure if this messed up anything.

  4. If you have lost your log-in information for any blog you can visit

    If required click the "Need More Help" link there and complete the required information for account recovery.

  5. Well, I already tried that. Giving my old username on this page redirects me to login page with my new username populated.

    I am not sure whats going on. I want to be able to atleast delete one. But I don't see it anywhere in my Dashboard.

  6. If you already clicked the "Need More Help" link there and completed the required information for account recovery then you will be receiving and email. Check in your email client spam filter for it please.

  7. Also, I do have my login details. I am logged into my account. In my Dashboard I see listed.

  8. I was referring to
    I tagged this thread for a Staff follow-up. Please subscribe to it so you are notified when they respond.

  9. Thank you. I am already subscribed to this topic. So should get the updates.

  10. PS - you need to be logged all the way out of all WordPress.COM accounts for the Need More Help to work correctly - if you are still logged in it will fill in the account name you are logged in as for you -

  11. Yep. Tried that. I filled the form and submitted. Got a message saying they will review and get back to me.

  12. So I think the issue is, I first changed the URL from to

    After that I changed my userName. When I changed my userName, it was mentioned that the old user name will be permanently deleted and cannot be recovered. I am wondering if it linked to the old username. It might have deleted the old username but did not delete or associate this new URL to the new username.

  13. The blog is associated with sdenthumdas, which has not been deleted.

  14. hmm..thats one of my other email addresses. I am not sure how this link got associated to that. But I was able to recover it. Thank you.

  15. You're welcome!

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.