Turning spell check off permanently

  • Author
    Posts
  • #265918

    gretak
    Member

    Is there any way to turn off the spell checker so that it goes away? It annoys me to no end, since I use many non-English names and words and inevitably every other word is underlined in red dots as I go. I have it turned off in my browser settings so I’m pretty sure it’s the WordPress spell check that is irritating me.

    Thanks.

    #266206

    wpvstp
    Member

    The WordPress spell checker is turned on/off by clicking on the spellchecker icon.

    #266215

    gretak
    Member

    Yes, but it only works for the text you’ve already typed; it doesn’t stay off permanently. I want to make it go away permanently.

    #266221

    It’s probably the spellchecker in your browser. Go to preferences and turn it off.

    #266227

    gretak
    Member

    I have turned off spellchecker in the browser (see initial post above).

    #266230

    wpvstp
    Member

    My WordPress spell checker only comes on when I click the icon. Click again to turn it off and it stays off. Permanently. What browser are you using?

    #266235

    teck07
    Member

    If your using Firefox it has spell checker built into the browser
    and it appears that the spell check option can not be turned off.

    #266236

    gretak
    Member

    I use Safari sometimes and Firefox sometimes, on an Intel Mac. :-(

    Maybe it’s a Mac thing.

    #266237

    gretak
    Member

    Ah teck07, thanks for the info re: Firefox. It is the browser I use the most.

    #266239

    teck07
    Member

    You’re welcome! gretak,

    #266243

    zabez
    Member

    If it is Firefox’s spell checker, you can right-click (or the mac equivalent) and add words to the dictionary (useful, if you have repeated names). In Firefox 2, at least, there’s an option for “check my spelling as you type” in the advanced options, if it gets too annoying.

    #266245

    teck07
    Member

    Just to re: point this this out it appears that
    you can not disable spell check with Firefox 3,

    #266249

    Hmmm, something is definitely wrong with FF 3. You can deselect the “check spelling as I type under preferences > advanced in the browsing section, but it still seems to check spelling.

    A bug me thinks.

    #266253

    zabez
    Member

    I’ve now upgraded (finally), and unchecking that does seem to turn off spell-checking, but only after you reload the current page or go to another one. I’m on Windows XP, which might make a difference.

    #266254

    Ah, I didn’t think of reloading the page. I can confirm that reloading the page works in Mac with FF 3.

    #266256

    teck07
    Member

    Oops my mistake I didn’t see the option to turn off Spell check with
    FF 3 I restarted my browser and the option appeared must be a bug with
    FF3,

The topic ‘Turning spell check off permanently’ is closed to new replies.