Twenty thirteen theme font problem

  • Author
    Posts
  • #2202764

    Hi,
    recently decided to switch to this theme, but there is a problem with the font. Description of blog, names of widgets and descriptions under images turns into squares not letters. See this screenshot http://media.snimka.bg/s1/4191/034625580-big.jpg?r=0

    P.S. I don’t use custom upgrades. I’ve used this theme some months ago without any problems.

    The blog I need help with is metalniat.wordpress.com.

    #2202865

    I tried testing this and I was unable to reproduce the problem. I used Firefox 34 on a Mac for my test. I researched the theme and noticed that the default font settings for the tagline in the Twenty Thirteen theme is set to:

    .site-description {
        font: italic 300 24px "Source Sans Pro",Helvetica,sans-serif;
    }

    If your computer has the Source Sans Pro or Helvetica fonts installed, then one of those should be used for the tagline as the first choice. If you don’t have either of those fonts installed on your system, then the system default sans-serif font should be used. It’s possible to change font settings locally.

    Do you know if you have either of those fonts installed or have you changed any of your local font settings that you know of?

    #2202866

    Until now I haven’t been in problems with this theme. I have these fonts

    #2202969

    I tested this again with the following steps:

    1. Set my test blog language and profile language to Bulgarian
    2. Updated my test blog tagline to “блог за ножове”
    3. Went to Appearance > Themes in the blog dashboard
    4. Searched for Twenty Thirteen
    5. Clicked the Preview button on the Twenty Thirteen theme

    The result of my test was that the tagline displays in either Helvetica on a Mac or Arial on Windows—which is the expected font that should display in the font stack if “Source Sans Pro” does not load. This is expected.

    Screenshot of my test: https://cloudup.com/c2avOuT2T8e

    I used Windows 8.1 and Firefox 34 in the test screenshot above.

    I think my test shows that the characters should load correctly on a computer where Source Sans Pro is not installed locally and the browser then falls back to the other fonts in the list (which is expected in this case).

    I also asked three other colleagues to help me test, and the results were the same as mine where the font displayed normally.

    It’s possible you have a local version of the Source Sans Pro font installed that does not have the required language support and could be the source of the problem. If the font worked for you before and doesn’t any more, I am not sure why that would be happening.

    If you’d like to debug further, I can recommend two possible steps. One option would be to try to check from a different computer just to see if the same problem happens in a different environment. Another option would be to try to check the font using the browser inspector to see which font is loading. If you want to give that a try, you can right-click on the tagline while you are previewing Twenty Thirteen in Firefox and click the “Inspect Element” option. Then look at the panel on the bottom right to see if there is a “Fonts” section. Click on “Fonts” and look to see what is displayed there. Here is what the fonts panel looks like: https://cloudup.com/c0OZMNV5dEr

    #2202977

    On other two computers with Windows 8.1 and Firefox 34 there’s no such problem. Very strange. On the problem machine I didn’t make any chamnegs in fonts and settings or in browser fonts.

    #2202978

    Okay. I’m not sure what happened on that computer, but it does sound like an issue with a local setting of some kind. Perhaps something is wrong with a local font? Or, browsers get updated all the time and sometimes add-ons or extensions are installed—those things get updated and changed and it’s possible one such update caused some trouble. There are a number of things that can cause odd display problems like you’ve described in this case. What I can to do help is first test everything myself to try to make sure it’s not a problem on the server side, and I think we’re good there, and then I can try to offer advice for troubleshooting on your side after that. Did you want to try to check in on the font itself? Using Firefox, if you right click and select “Inspect Element” you might be able to see the Fonts panel and that will give you a good idea about what font is being used by the browser. Another good test would be to check another browser on the same computer to see if the same problem happens. If it doesn’t, then that narrows the problem down to a browser setting or add-on in the first browser where the problem is happening.

    #2202979

    Thank you, I’ll check which font is using. I don’t have addons installed. In chrome there is no problem. I’ll reinstall Firefox

    #2202980

    Just out of curiosity, were you able to check to see what Font is showing if you look in Firefox’s browser tools? https://cloudup.com/c0OZMNV5dEr If that shows Source Sans Pro and says “system” somewhere, then I would recommend reinstalling the font before reinstalling the browser—or even just uninstalling it as a test. The Source Sans Pro font is a free, open source font.

    You might also try clearing your browser cache as a troubleshooting step:
    http://en.support.wordpress.com/browser-issues/#clearing-your-browser-cache

    #2202983

    I’ll check later and write here, because not on this computer now. I’ve cleared cache 3 times but without effect.

    #2202985

    The system uses Source Sans Pro instead of Arial. On computers without problem is Arial.

    #2202991

    You might try reinstalling the Source Sans Pro font locally and make sure you get a copy that has Bulgarian language support, the one from Google Fonts does not.

    Good luck! Would love to hear an update back if you get it working. :)

    #2202992

    I’m using now different theme. Thank you

The topic ‘Twenty thirteen theme font problem’ is closed to new replies.