Need help? Check out our Support site, then

Twitter can't connect to publicize

  1. dutchgamedesign

    Hi guys,
    Everytime I have new followers on twitter, I have to reconnect my twitter acount to my wordpress acount to see how many followers I have on the mainpage. Is their no other way?

    But now I have a new problem, I can't connect it anymore. When I look at my stats at publicize, it doesnt show my twitter acount and my followers. I saiz that im connected when I retry but it isn't. I tried to delete my cookies and history but no response.

    Please help out!
    Thanks in advance


    The blog I need help with is

  2. gordonwellsuist

    I'm having the same problem with

    That is, after disconnecting and reconnecting, the Twitter followers no longer show up on the Followers listing on the Stats page. They've just disappeared. (Facebook followers are still showing.)

    Any suggestions or help welcome.


  3. Does this help?
    Publicize Follower Counts not showing, or showing incorrectly

  4. gordonwellsuist

    Thanks, timethief, but no, I'm afraid it doesn't. I've disconnected and reconnected several times, but the Twitter follower number does not resurface.

  5. @gordonwellsuist Have you tried posting a new post since you did that?

  6. Hi,
    I'm having the same problem as m.a.
    Lost my Twitter list followers. After disconnecting and connecting I don't see the list. (Facebook followers are still showing.)
    Your advice !!

  7. Quoting justjennifer:

    Have you tried posting a new post since you did that?

  8. No. should it help?

  9. Hi,
    To all who are still fighting. !!!

    Just published a new post and THE TWITTER LIST IS BACK !!!

    Thank you.

  10. Staff stated this:

    Publishing something and Publicizing it out to those services. The number is automatically refreshed each time you Publicize something, so the next time you publish, it should fix itself magically.

  11. Twitter list followers - of course !

  12. Understood. You did what Staff said to do and it worked.

Topic Closed

This topic has been closed to new replies.

About this Topic