Need help? Check out our Support site, then

Two hours worth of edits lost, reverted to original draft

  1. I've been working for about 2 hours on a draft blog post in Firefox 12.0. I've been working in both the Visual and the HTML editors. Some of what I've been doing has been inserting images and editing their presentation in the HTML code.

    After a recent Save I suddenly realised that the entire post had reverted to the original draft post I started with 2 hours ago. That's so much work lost. I have been saving the draft regularly as I go. Is there somewhere I can bring back a more recent draft? I am heartbroken to have lost all of this work for no apparent reason.

    The blog I need help with is

  2. Check the Revisions module for previous saved versions. If you're not seeing the Revisions module while on the post editor screen, click Screen Options (top right) to activate it.

    And in general avoid using drafts (there's a glitch that has been going on for months, lots of users have been complaining about disappearing drafts, and so far WP has nothing to say about this). When you start a new post, write a couple of lines, set the visibility to private, publish the post, continue editing and updating, turn to public when finished.

  3. Oh justpi thank you so much: that worked! I can't thank you enough, I've just been sitting here sobbing, which is not like me at all. Would offer to buy you a drink or send you chocolates, depending on what you prefer, but maybe that is inappropriate on this board :-)

  4. You're welcome!

  5. I do not see revisions under screen options when in the all posts. I created a draft just to test and it is still not there but it is under the posts. earlier today I had approx 10 drafts and they are nowhere to be found. are they deleted after publish?

  6. a) Each dashboard screen has different screen options. The Revisions module is part of the post editor screen: the one you see if you go to Posts > Add New, or if you go to Posts > All Posts, hover over over the title of a post and click Edit.

    b) "It is still not there but it is under the posts." What does that mean?

Topic Closed

This topic has been closed to new replies.

About this Topic