typekit doesn’t work

  • Author
    Posts
  • #552022

    I’ve been using typekit for some months but lately, it doesn’t work. Is it because of the change in theme? Any ideas?

    The blog I need help with is hindiakoto.wordpress.com.

    #552134

    timethief
    Member

    Can you provide more detail please?
    In what way does it not work?
    What change in theme? From which theme to which theme?
    Have you tried looking here? http://typekit.assistly.com/customer/portal/articles/6840-using-typekit-with-wordpress-com
    Have you tried contacting TypeKit Support? http://typekit.com/help

    #552164

    justjennifer
    Moderator

    If you’ve changed themes, you may have to re-enter your CSS selectors on TypeKit.

    Also, that TK support doc seems to be out of date. I’ve been TypeKit from the start when I switched to Twenty Ten, but Twenty Ten isn’t mentioned in that list, although Pressrow and Cutline both are. And, the WordPress.com News post announcing it uses it on Paperpunch, which also isn’t mentioned.

    Here’s the original link to TypeKit from the WordPress.com News entry about Paperpunch:
    http://typekit.zendesk.com/entries/121731-using-typekit-with-wordpress

    #552166

    justjennifer
    Moderator

    I’ve also just posted a comment on the TypeKit blog, which conveniently is hosted by WordPress.com. Will let you know if they reply.

    #552343

    I used Motion. Typekit works when I was using that theme.

    Then I used Zbench. Then now I’m using Under the Influence. Typekit doesn’t work on both themes.

    The font I selected on typekit doesn’t appear on my blog.The font doesn’t change into, for example, Droid Serif.

    #552344

    I’ve tried deleting my Typekit account then making another one. It still doesn’t work.

    #552357

    justjennifer
    Moderator

    As I mentioned above, it’s possible that you need to redefine the CSS selectors for the new theme in your Typekit Editor on Typekit.

    According to the reply I received on the Typekit blog, setting up Typekit in the themes mentioned in the support document that timethief pointed to are more “automatic” than WordPress.com’s other themes, but they support all WordPress.com themes as long as you know what your HTML/CSS selectors are.

    Where in your blog are you expecting the Typekit fonts to appear, Blog title, Post header, etc.?

The topic ‘typekit doesn’t work’ is closed to new replies.