Need help? Check out our Support site, then

Unable to Comment on Other Blogs

  1. I replied to a previously existing thread over a week ago (link), but never received a response of any sort, so maybe starting my own thread is the way to go?

    It's not happening everywhere, I can comment on my own blog just fine, but when I visit other blogs I have to login again (even though I'm already logged in) and then get a "Sorry, this comment could not be posted." notice.

    Currently using Chrome 29 and cookies are enabled, cache has been cleared several times since this started happening last week.

    I have since tried commenting on other blogs using mobile Safari on my iOS devices, using the WordPress app for iOS AND using the mobile browser on my Nook, but am unable to comment using any of these.

    Third party cookies are enabled on all browsers, caches have been cleared repeatedly, but I am completely unable to comment on any blog other than my own.

    This is sincerely frustrating and I'm hoping that there is something that someone can do to help me.

    For what it's worth, I AM able to comment on blogs, where I have to enter my information prior to commenting, as well as on a blog where I am admin. I only can not comment on blogs that are not my own.

    Thank you.

    The blog I need help with is

  2. l have tagged this thread for Staff assistance. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

    1. If applicable see here for instructions on how to clear the cache for Chrome and Safari on the iPad:

    2. Try enabling HTTPS:
    Add both * and * to your list of trusted sites under the Security tab. Make sure to uncheck the box for “Require server verification (https:) for all sites in this zone.”

  3. When you go to leave a comment on a blog, are you showing up as being logged in, or are you being asked to log in first? If you are being asked to log in, can you tell me the exact message you receive when the process fails (or better yet, take a screenshot and post it to your blog's media library for me to see):

    Are you able to log in via Facebook or Twitter?

    Or is the issue that you are able to log in and make a comment, but it never appears?

  4. There is already a link to a screenshot of the error message in my original post.

    I will be logged in on my blog. I visit another blog and am logged out. I click the wordpress button to log in and then comment. Receive error message and no comment is posted. Refresh, try again (still logged in this time), receive same error message "Sorry, this comment could not be posted," (again, click the link with that text in my OP for a screenshot.

    I have not attempted with fb or twitter because I keep WordPress separate from both.

  5. Yes, which is also in the blockquoted portion of my first post in this thread where I reiterated my original post from 11 days ago. I have another screenshot from earlier today which shows exactly the same thing, should I post that as well?

    That's the only error message I'm receiving, as it LOOKS like I am logged in when I click Comment.

  6. To confirm, when you initially go to leave a comment, it sounds like you're not logged in. In other words, you don't see something that looks like this:

    Instead, it looks like this?

    When you fill in your details, are you absolutely certain you are using the same email address in the form as you have listed here?

    If you try to use a different email address, you may run into trouble logging in.

  7. Correct w/r/t the first two screenshots.

    I log in using my user name (which autocompletes) and it appears as though I am logged in correctly (I am able to "like" posts, as I actually am logged in) - I can see my gravatar under the comment box and everything. But when I click on Comment, I'm told my comment could not be posted.

    As an example:

    My wp dashboard is open in one tab of my browser. I receive notification in another tab (whether it's email, twitter, fb, whathaveyou) that there is a post I am interested in reading. I click the link to said post, and am no longer logged in (even though I am currently logged in in another tab) when I go to comment.

    I click the WP button below the comment box to login. I am logged in. I am able to like the post. I enter a comment and click the comment button. The screen goes completely white EXCEPT FOR "Your comment cannot be posted."

    I hit my browser's back button, refresh. This time it appears as though I am logged in. I have the WP header at the top that indicates I am following this blog and have liked this post. Attempt comment again with same result.

  8. Also (sorry for double commenting), I feel it bears mentioning that I'm staying logged into all other websites (gmail, twitter, facebook, goodreads, etc), which indicates to me that it is a issue, not a cookie issue.

  9. This issue really sounds like cookies to me, as your browser is not keeping a persistent login for you on

    Please go to and let me know what it says under "Checking your browser…"

    Have you tried using a different browser to see if commenting works for you then? That would allow us to rule out cookies/browser issues.

  10. There's a check mark and in green it says "Great! Third party cookies are properly enabled in your browser!"

    I've tried via the latest Chrome on my laptop, via mobile Safari for iOS and the stock Android browser on my Nook.

  11. Thanks for all of your details. I am going to check with our developers to see if they have any further suggestions or if something may be going wrong. I appreciate your patience while I look into this for you.

  12. drbillorthosphere

    In case it is useful to know, I am having the same problem, exactly. Happens on firefox and ie and from multiple computers.

  13. I could moderate the comments of others and I could access the dashboard and publish posts - but I couldn't leave a comment. chicken coop kits

  14. Same problem here... although it seems to only be on custom domain websites... could be mistaken...


  15. @sbmumair123, it looks like your account is being caught as spam. You should contact Akismet here:

    For the rest of you, our developers are continuing to investigate this issue, but have not yet figured out what may be causing the problem.

  16. Honestly, I'm kind of thrilled I'm not alone with this issue.

    Jackie, thanks for letting us know it's being investigated.

  17. Just checking in as a "me too".

    I just tried to post a comment on a video and it sent me to a plain error page at the URL saying only: "Sorry, this comment could not be posted."

    I was logged in to my account, using Firefox 18 on OS X.

  18. This happened to me before and it is because my browser was not updated.

  19. I am having the same problem. Even when I'm using (logged in) my own wordpress site I'm not able to post comments in some of the sites. Though I'm easily able to post comment on my site. I have seen that problem is coming when I'm visiting the self-hosted site(like- but is not there when I'm posting comment on wordpress hosted sites (like-

  20. Hi. Please do check this problem.

  21. We have been able to reproduce the issue but have not yet resolved it. Please bear with us as our team continues to work on this.

    Also monmon, you may wish to contact Akismet, as your account also appears to be getting flagged as spam:

  22. I get this too.

  23. As we are aware of the problem, please only post in this thread if the situation changes for you or you have additional information to contribute.

  24. Jackie, that was years ago and I am totally okay now. Thank you, though :)

  25. We have just implemented a fix that should resolve this issue for some of you. If you are still experiencing this issue, please let me know the addresses of sites you cannot comment on so we can investigate this further.

  26. I just tested it and was able to comment successfully. THANK YOU!

  27. Hi, I just tested it, I'm successfully able to comment on these pages but I'm still not able to like them.

  28. Hi, Just tested the comments and I am able to comment now... however, the like function does not work. - Example page:

    A pop-up window loads, but then closes a moment later with the like not updating...

  29. forgot to say thanks for getting the one part working... ;-)

Topic Closed

This topic has been closed to new replies.

About this Topic