unable to edit a post

  • Author
  • #1107578



    I need help with this post: ojrakreloaded.wordpress.com/2012/12/25/membuka-gembok-tanpa-kunci/

    I wrote it 3 days ago, saved it as draft, preview: everything looked fine. Hit publish and do other stuff.

    Today, I found as if the paragraphs had duplicated themselves with a more tag between original and copy. If you read Indonesian, you may see that in that post I said (almost) everything twice.

    “it’s okay,” I thought, “maybe my stupid.”

    So I hit Edit, delete the duplicate part, pressed Update. Nothing happened. Tried many times after that using both my laptop and this cellphone. Still nothing happened. What happened?

    By the way, happy holidays, everyone!

    Oh, one more thing: is it possible to unlike a post? Because I accidently hit Like when I meant to click Edit. I think it is ridiculous to like one’s own post.

    The blog I need help with is ojrakreloaded.wordpress.com.



    I think if you click Like again it removes it.

    There are many people reporting odd problems posting, and things not showing up. The problems are associated with posting from the “new dashboard” ie the WordPress.com central page, and the Add New Post button on the admin bar. IF you post via Dashboard->Posts->New Post all should work okay.

    Can you give us a link to the post in question? We need to see the code.



    Here: http://ojrakreloaded.wordpress.com/2012/12/25/

    Thank you, Rain :)




    If you read the post from home page, you’di see a more tag right after the end of the post. “cuma gembok kecil” supposed to end the post. But if you clicked ‘more’, you’d feel like de javu. ;D



    Well, I’m afraid I don’t see anything weird about the code. I flagged this for staff to look at, which is the best I can do. Good luck.

    Meanwhile, try Windows Live Writer or Ecto to write long posts. They always save a copy to your hard drive.



    Much appreciated. Thank you.



    Hi there! Sorry to hear that you ran into this trouble :( I checked your post now and I see that you were able to edit the post in question and remove the duplicate text, so that’s good news.

    If you have a minute, could you please let me know how you created the post (which browser, and what menu option), at what point did you add the “more” tag, and how did you fix it in the end? I would like to see if I can reproduce the issue that you ran into it.

    Oh, one more thing: is it possible to unlike a post?

    Yes, if you click the “Like” button again, the page reloads and your like is removed. The notification that you liked their post would have been sent to the post author, though.

    And belated happy holidays to you too :)



    Ah, Jenia, hi!

    1. I wrote and publish the post from WordPress for BlackBerry app.

    2. I put the more tag like this: “Here’s a tip. Untuk membuka gembok dengan kawat, Anda butuh :more-tag-here: kawat yang kuat tapi tidak begitu kaku.”

    As I checked the post (on my blog, home page) just after it’s updated, the more tag was sitting right where I wanted it to be. 3 days later, it’s moved.

    Before I started this thread, I’ve tried to fix it using Windows Firefox, Opera Mini, and of course, WP4BB: delete the duplicate part including the more tag –> hit Update –> the deleted part was back again. Tried several times. Nothing worked.

    Then I exported that post to my offline blog (WP 3.4), edit, update, checked: it’s fixed!

    So I went back online (using Opera Mini on my mobile, since my kids were screaming for Plants vs. Zombie), and did this:

    1. Open Post editor, html mode.
    2. Delete entire text, update. Result: the post had no entry; only title.
    3. Copy paragraph one from WP4BB post editor, paste that one paragraph to the post editor on Opera Mini, hit update, see blog’s home… Result: post now had one paragraph, and no Read more link.
    4. Repeated steps in point 3 to paragraph two, three, four, and on to the very last paragraph. Result: post fixed; more tag’s gone, and no duplicate text.

    I added one paragraph after one paragraph to find if there’s anything that’s not supossed to exist in that post of mine. If there’s something, I wanted to know where it’s at, so I could do some fixing. But there was nothing; no weird codes, no nothing, and I got oh so perplexed! Because, Jenia, I had tried copying all paragraphs at once, before copying them one by one, and it didn’t fix it.



    Thank you for all the additional detail, Yella. I can imagine how frustrating it was to get the post back to working! Let me look further into this to see if I can reproduce or find any related cases, and I’ll get back to you.



    Hi Yella, so it looks like a bug with the “more” tag. Trac ticket to watch: http://blackberry.trac.wordpress.org/ticket/259

    Until this is fixed, I recommend not using the “more” tag with the BlackBerry app, or if you are using it, remember that you will be able to update the content after and before the “more” tag within the app, but you will likely run into issues if you want to remove the “more” tag (duplicate content, inability to remove the tag).

    Thanks for raising a flag on this one, and sorry for the inconvenience!

The topic ‘unable to edit a post’ is closed to new replies.