Need help? Check out our Support site, then

Unable to Embed Facebook Posts

  1. Hi there - I've read the instructions on how to embed FB posts into my blog. I've also tried a number of different variations (pasting the url, pasting the embed code from FB etc). The posts are public etc.

    Have I missed something? Has anyone else had this problem and found the magic solution? Cheers, Jacqi

    The blog I need help with is

  2. What specific problem are you encountering? Can you give us a link to a post of yours with a FB post embedded? Have you ensured that the post is visible to the Public, not just the person;s Friends list?

  3. The problem is that it shows as a link only - not the beautiful FB post I was hoping for. It is a totally public post from a FB page...

    Here is a link to a test post I just published to give you an idea of what I'm seeing.

    Thanks for your interest :)

  4. Use the "unlink" button to remove the link. The button looks like a broken link and is next to the button where you create a link. (#11 here)

  5. I've already doesn't change anything... These are the instructions I'm trying to follow (here)

  6. How very odd. It worked entirely fine in my demo blog's test post. I also switched to a preview of Gridspace (premium theme so I can't actually test it in full) and the FB post appeared. So not a problem with the theme. (screenshot)

    Are you sure the URL is on its own separate line with no other code in that line and the link is not linked? See this Support doc on the FB embeds:

  7. Does NOTHING change when you put the cursor on the link and hit Unlink? No change in colour, nothing? You have to be in the Visual editor.

  8. same problem here. unlinking it does nothing-doesnt change the color.
    heres the post with the link put in 4 different ways, in visual, text, unlinked, etc

  9. I see the Facebook embeds, plus three links.

  10. thats awesome, thanks to whomever flipped the switch... i saw they were all now working on iphone, safari and IE9, which they werent at time of posting this on any of the 3. it was just showing with one link twice and another link 3 times.
    to clean things up now, i deleted one of the 2 that were showing and 2 of the 3 that were, leaving one of each different identical one, just in case, since i have no idea why or which works or why/why not.
    and it no longer embedded anything.
    i restored to the edit that worked so it is live again showing extra links and the embed twice. can anyone tell me which lines of code are working, which are working twice and which aren't doing anything since they are 2 unique identical lines? or are there just lines of code and two of the same embed required to make it work. code:!/photo.php?fbid=636693253019977&set=a.523998207622816.114621.465511966804774&type=1!/photo.php?fbid=636693253019977&set=a.523998207622816.114621.465511966804774&type=1!/photo.php?fbid=636693253019977&set=a.523998207622816.114621.465511966804774&type=1!/photo.php?fbid=636693253019977&set=a.523998207622816.114621.465511966804774&type=1!/photo.php?fbid=636693253019977&set=a.523998207622816.114621.465511966804774&type=1

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.