Unable to import from my Posterous backup

  • Author
  • #1158907


    I have been trying to import my posterous posts to my wordpress site (http://technikhil.wordpress.com/) but have been unable to do so.

    I followed the instructions in your guide and created a backup of all my posts using the posterous backup tool and downloaded and unzipped the backup on my Mac.

    Then I went to the import page and tried to upload the xml file – wordpress_export_1.xml

    However every time I try to import I get the following error –
    “Sorry, there has been an error.
    Could not read the XML file. Please make sure you are uploading a valid .xml or .xml.gz file. For more info, please see our documentation.”

    I have re-downloaded the backup file from posterous several times and tried but I keep getting stuck at this step. I am not sure why this error is occurring.

    Has anyone experienced this issue or have any pointers as to what I should be doing?

    The blog I need help with is technikhil.wordpress.com.



    Same here.



    I think this is a recent development as in the forums I have seen similar issues last year having been resolved. Maybe Posterous changed something in the backup format…


    I seem to be having the same problem. Did we have a resolution to this.



    You cannot upload a .zip file. It must be an xml file.
    reference link > http://en.support.wordpress.com/import/import-from-posterous/

    I tagged this thread for a Staff follow-up. Please subscribe to it so you are notified when they respond.


    Thanks a lot.
    I understand that zip file cannot be uploaded. I unzipped the download from Posterous and am trying to upload the wordpress_export_1.xml file but it gives me the error stated above.
    I have now tried the backup twice from Posterous, in case the download was corrupt the first time but in vain.
    The XML file looks fine in itself with all the relevant headers and tags in place.



    It looks like you tried the WordPress importer first rather than the Posterous importer. I also didn’t see any errors in your second attempt using the Posterous importer. Have you looked in your posts to see if the import was successful?

    If you still don’t see the posts, let me know and I’ll try the import on our end.

    Thank you!


    Hi, Thanks for checking, but I do not see any of my posts imported from Posterous. Now when I try to import it, the text box before ‘Browse’ just goes blank and nothing happens. Appreciate if you can help. Thanks a lot.



    I tried again a few days back and the import was successful. I am still going through all the posts but for the most part since they were straight markup with iframes embedded, it seems to have been cleanly imported.




    @technikhil – Just a note that WordPress.com doesn’t allow the use of codes such as embed, frame, iframe, form, input, object, and textarea. Those codes are not allowed on WordPress.com for security reasons. Here’s more information on why code like that isn’t allowed:



    @providencephotos – I have completed the import for you. I hope that helps!


    @csonnek – Thanks a ton. All of them are now there. Now for some blogging. Really appreciate the help. Apologies for the delayed response.


    I successfully imported my blog from Posterous to WordPress.com — thanks to all for the tips. With one month to go before Posterous closes, many Posterous bloggers will be making the switch.

    Just FYI…I could only extract the Posterous zip file on my Mac, not my PC.



    I can’t unzip the Posterous file, which means that I can’t upload anything to the WordPress importer… How do I fix it?


    If you cannot unzip the file on your Mac, then try contacting Posterous Support:


    Good luck!

The topic ‘Unable to import from my Posterous backup’ is closed to new replies.