Need help? Check out our Support site, then

Unable to install Jetpack

  1. Hi,

    My website is

    In the last few days, I updated Jetpack to the latest release after which Jetpack has stopped working.

    I get this message:

    Downloading install package from…
    Unpacking the package…
    Destination folder already exists. /home/debesqku/public_html/wp-content/plugins/jetpack/
    Plugin install failed.

    Please note that ALL other plugins have been uninstalled and the problem still persists.

    Cache and cookies have been cleared.

    I have seen all the FAQs.

    Could you help me out here please? Thanks.

    The blog I need help with is

  2. Do you have FTP access to your site? If so, manually delete the 'jetpack' folder inside /public_html/wp-content/plugins/jetpack/ . Then try to install the Jetpack plugin again.

  3. Thanks Kardotim. I do have access, but I wanted to check if my stats will remain intact after I delete that folder of will all the stats for social plugins start again from zero... i.e. Facebook likes and shares, PinIts, etc.

    Many thanks in advance.

  4. Everything will remain intact because the data is stored on our servers.

  5. Thanks Kardotim. I did as you suggested and deleted that directory. Now I get this message on installation:

    Downloading install package from…

    Unpacking the package…

    Could not create directory. /home/debesqku/public_html/wp-content/upgrade/jetpack.tmp

  6. The /wp-content/upgrade directory needs to have read/write permissions set to 777 . You can change the permissions by right clicking on the directory when accessing it through FTP.

  7. There is no such file/folder in the wp-content folder what do I do?

  8. I hope you got what I meant not sure if you did. Thanks for helping me out.

  9. And I am unable to create a folder in wp-content also.

  10. I see. In that case try to change the permissions of the folder above /upgrade, which is /wp-content.

  11. Thanks Kardotim. I have done that and tried changing permissions to 777 already, but it still doesn't work. I cannot create the folder /upgrade even then.

    I really appreciate you helping me out here, and would be grateful for a solution.

  12. You mean that the folder can't be created when installing the plugin? or did you try to do it manually? You might want to try it manually.

    Also take a look at this guide to learn more about permissions.

    If the above doesn't work for you, I suggest contacting your host and help you set the correct folder permission. If setting the permission to 755 doesn't work, try 777. The lower the number the more secure it is. In this case 755 is more secure than 777.

  13. I tried both - an installation in the WP Dashboard and also doing it manually.

    I'd read that Codex and tried - I can change the permissions for the wp-content folder (and other folders too), but cannot seem to create an "upgrade" folder.

  14. You could try to follow the steps in this guide instead:

    Otherwise contact your web host. They should be able to change the folder permissions for you.

  15. I finally spoke with my web host and they resolved it for me by changing folder permissions of this particular directory - there was some glitch there. Thanks so very much Kardotim. I am most grateful.

  16. Awesome! You're welcome.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.