Unable to purchase domain mapping

  • Author
    Posts
  • #1914191

    Hi,

    I have been trying to purchase domain mapping from WordPress for the past few months. Whether I try to pay by credit card or Paypal, both don’t work. It shows an “invalid payment” error message.

    WordPress has told me to go to Paypal. And so, I did. Paypal has checked my account and there is nothing wrong. Singapore is also not a blocked country. I have showed them a screen shot of the error page, they said the problem lies with WordPress.

    Is there anyone whom I can email in WordPress for me to show the screen shot, or can WordPress look into this, or liaise with Paypal to resolve it?

    The blog I need help with is socialosophysg.wordpress.com.

    #1914351

    rootjosh
    Staff

    I’m not seeing any failed transactions on this user account. Just to clarify, is this the account that you have been logged into when you have tried to upgrade?

    #1914367

    Yes, this is the account. Maybe I should run my steps through with you to see if we can identify what is the issue here?

    Steps I’ve taken:
    1. Click on “Domains”
    2. Click on “Map a domain name you already own”
    3. Key in URL, and click on “Yes, I already own this domain name. Map it to my WordPress blog”
    4. Click on “Paypal” tab
    5. Click on “Purchase Domain Mapping for $13.00 USD”

    I don’t get the chance to log into my Paypal account, after a short while showing “processing”, I get the error message on the top of the page which says “Invalid Payment”. Same goes, if I opt for credit card payment, after entering my credit card details, I get the same error message.

    I’ve tried it on various computers, asked a friend to try with his credit card and Paypal account, to no avail.

    Please help.

    #1914429

    rootjosh
    Staff

    What is the domain you are trying to map?

    #1914435

    blog.socialosophy.com.sg

    #1914441

    rootjosh
    Staff

    I’ve gone ahead and added that Domain Mapping for you.

    I will look into the payment issue so that hopefully you won’t have the issue again in the future.

    #1914453

    Great. Thank you Rootjosh!

    #1914455

    rootjosh
    Staff

    Happy to help and my apologies for the hassle.

The topic ‘Unable to purchase domain mapping’ is closed to new replies.