Unable to read posts via Windows Live Writer

  • Author
    Posts
  • #430980

    I have just discovered offline editing using Windows Live Writer and have hit a snag. Although I can make new posts without any problems, I am having problems when I try to get a list of posts from my blog…

    The response to the metaWeblog.getRecentPosts method received from the blog server was invalid:
    Invalid response document returned from XmlRpc server

    I discovered that this problem was due to the presence of smileys in some of the posts. Great, I thought! So I fixed those posts and tried again. I can now read the 1st 50 posts, but cannot read the 1st 100 posts. I’ve had a quick look in posts 51 to 100 and cannot see anything out of the ordinary.

    Any ideas?

    The blog I need help with is brickiesgazette.wordpress.com.

    #431107

    raincoaster
    Member

    I’d report that to staff. The smiley thing is something they’ll have to investigate.

    http://support.wordpress.com/contact

    #431116

    Thanks – I have done that. Its a shame that WLW cannot be told just how many posts to read (instead of 20, 50, 100, 500) then I could easily find the cause of the 2nd problem!

    #431118

    OK – I’ve figured the 2nd problem (which I will pass onto support).

    I have a post which contains a link to one of the admin pages (./wp-admin/media-upload.php?post_id=xxxx) and this caused WLW the problem.

    #431119

    raincoaster
    Member

    Ah, good catch.

The topic ‘Unable to read posts via Windows Live Writer’ is closed to new replies.