Need help? Check out our Support site, then

Glitch: Why can't I register a domain that contains an apostrophe and a space?

  1. I have tried repeatedly to purchase and register the domain name for my wordpress blog, but each time I fill out the domain registration form, it is rejected because a backslash () is inserted in the organization name, Duttenhofer's Books. I type in "Duttenhofer's Books," but when I submit the registration, it shows "Duttenhofer's Books" and says 'The “Organization” field can only contain the following characters: a-z A-Z 0-9 . , ( ) @ & ' - ! + [space]'.
    Blog url:

  2. I typed the backslash, as needed to describe this problem, but it does not appear in the text above. It belongs between the parentheses, and before the apostrophe i.e.
    it shows "Duttenhoferbackslash's Books"

  3. That isn't a glitch. Custom domains cannot contain spaces or apostrophes. Custom domains can only contain letters, numbers, and hyphens.

    You could register .

    Site titles can include spaces and apostrophes. You can change your site title at . Please see our support resources for information about your General Settings at .

  4. The domain name I am attempting to register -- -- does not contain an apostrophe, space, or any such thing. The glitch occurs when I fill out the information form for paying for the domain. It asks for my name, address, etc, and for my "organization," and it is in the "organization" field that the backslash inserts itself into the bookstore's name.

  5. To clarify, I myself am not typing the backslash keystroke at all. It appears on its own when I try to register and pay for the domain.

  6. Can you please tell us what browser (and version of) you're using?

  7. Mozilla Firefox 3.6.23. Thanks.

  8. That a pretty out-dated version of Firefox, I bet it might have something to do with the issue.

    Can you upgrade to the latest (currently 7.0)?

  9. Firefox "check for updates" says "no updates available." I will try another browser. Thanks,

  10. I tried Internet Explorer, and exactly the same thing happened. I guess I will try it on another computer.

  11. That is very odd, please let us know if it continues on a different computer.

Topic Closed

This topic has been closed to new replies.

About this Topic