Unable to remove text widgets since dashboard change

  • Author
  • #215596


    The title says it all. I went to remove a text widget and found that it just snapped back into place again. I clicked on edit and I could not see all of the text in the widget in order to edit it. I tried deleting all the text in the widget. I was able to do this, but now the widget still shows on the blog page as a blank space. And now I am not able to type any text into the widget.
    Very annoying.
    Please help?


    To remove a text widget, or any widget from the side bar, click on the edit link in the widget and then click on the “remove” button.

    In IE6 and 7, if you open a widget to edit the left half of it is cut off. Hopefully this issue will be solved in a little bit, but in the meantime, download and use Firefox as it does not have this issue. Once the issue is solved, then if you wish you can uninstall Firefox and go back to using IE.



    I’m having the same issue. When I open my text widgets, the remove button doesn’t appear-only half the box is viewable. And I can’t download firefox.

    Any other suggestions?


    I am having the same issue. Well, I can use another computer with Firefox. What about you cahterinette?



    I am having the same issues with my text widgets as well as vodpod. The widgets open up underneath the unused widgets list and all of cannot be seen. Marianne has been the tech to respond twice and she has not addressed the problem yet, thougfh I have gone through all the steps she has asked me to do. I mainyain a blog page for a volunteer group and it has the same issues and I can’t load code for more pictures into a text widget because it won’t open up. Does anyone have an answer for this????


    The only solution till they get the IE bugs fixed is to download and use Firefox for working with WordPress. Once the bugs are fixed, then you can uninstall FF if you wish, and go back to IE.



    hi there, i’m sad to report that this issue goes further than the ie6 issue, some text widgets become completely uneditable after the text/code has been entered, and you are left with a widget you can’t get rid of, particularly annoying if you made a hash of the code you put in it!



    I have the same problem. And I use Firefox…


    I have the same problem too and I am using firefox.



    I had the same problem (widgets non editable) with Firefox, IE 7.0.6001.18000, and Safari 3.1.1 (525.17) all on Vista 32-bit. This is with WordPress 2.5.0 using the my Wacom graphics tablet (and Vista) in tablet mode. Using A) the keyboard to navigate in Firefox/IE or B) switching my tablet to mouse mode allowed me to edit the widgets.

    I couldn’t navigate the widget panel using the keyboard in Safari (Apple isn’t as accessible friendly as they’d like us to believe).



    Thanks darian, I had the same problem and your description of your approach allowed me to fix it. Someone else in another thread said “Use Tab” but what I did was click on the widget and then hit the Tab key, instead of just using Tab to move through the various fields on the page.



    hi there again peeps, this still doesn’t address the issue i stated previously, was hoping that 2.5.1 would fix it but no luck here, my problem isn’t the navigation of the widget page, but the fact that there is no ‘edit’ link on the text widget, you can drag and drop it anywhere you like but it doesn’t actually go anywhere…
    i did find a tutorial to manually remove widgets
    but it’s a bit of a ‘long-ting’…



    I am having the same problem using Firefox. There is no edit button showing on my text widget for me to remove it. rampy.wordpress.com



    @ thesacredpath

    “In IE6 and 7, if you open a widget to edit the left half of it is cut off.”

    I use IE7 and I don’t have that happen to me at all. My “remove” option is visible and when I want to “Edit” I do indeed see everything in the box. What still annoys me though, is no ability to copy from within the text widget editing box. I am able to use the backspace key to remove content, and I am able to type in new content and even to paste in new content, but not able to highlight and copy or use control ‘c’ to copy. This can be really annoying.

    For example, my fuelmyblog fuelroll is long and because we have to use the html option, has so many lines of html code. Because it can’t auto update like a javascript version would be, if i want to change my fuelroll in my blog to match my fuelroll after I add or remove people to it at fuelmyblog, I must do it manually.

    Before the changes here, I could highlight and paste a new set of code when I needed to. Now, I can’t highlight and backspacing it all out is a horrendous waste of time. It takes forever!

    I wish they would address that too.

    But as to why I on IE7 don’t experience that ‘half-box’ problem… I don’t know. I’m just thankful I can still find a way to edit my textboxes.



    Unbelievable. Something works in IE that doesn’t work in FF. I had the same problem as above. Edit link disappeared from my Text Widget. Opened it up in IE7 and voila, edit button.



    FF isn’t always the end-all and be-all. I was using a theme that rendered perfectly in IE, but entire chunks of the sidebar and About page were missing in FF. It happens.



    Hey guys I found it!
    I’ve got Firefox 2.0 and I had the same problem: THERE WAS NO EDIT BUTTON. I could move the widget as I wished, but couldn’t do anything else.
    However, I tried using the TAB key for selecting the widget and… guess what? I was able to select it! Then I pressed ENTER and the widget opened normally, with its “Remove” button. I clicked on it and the widget was gone ;)
    Hope to have helped someone!
    Keep on blogging!


    I’m like fracas. I use IE7 and have no problems with anything being cut off or being able to edit. But I also used to be able to copy/paste within the text box and can no longer do that.


    Just curious if the fact that I’m having no problems in IE7 has to do with the recent huge upgrades for Windows XP and Windows Vista. I downloaded the upgrade and am wondering if those who are having issues are ones who have not done the upgrade? It may behoove people to get the new service pack microsoft released:




    I had the same problem too. It works fine in IE though (for me anyway). Not in FireFox

The topic ‘Unable to remove text widgets since dashboard change’ is closed to new replies.