Unable to upload media to a new post, unable to edit links

  • Author
  • #1136257

    I am editing brooklynmusic.wordpress.com on various Mac computers. My theme is Journalist 1.3.

    My browsers are Firefox 18 browser, and when problems arise, also Safari 5.1.7 and Chrome 24.0.
    I have posted about this issue in the past at
    and also at

    I followed MacManx’s advice (posted on October 18, 2012) and have gone via “Users” > “Personal Settings” to set the Browser Connection so it says “Always use HTTPS when visiting administration pages”

    But still, at this time, I am experiencing the same issues:
    I can not upload images directly into my new posts. The “Add Media” button on my “Edit Post” page doesn’t react to a click.

    I can upload to the media library, but am having a devil of a time trying get the images into the desired post.

    In addition, if I highlight a bit of text and then go and click on the “link” icon on my Visual editor, the “Insert/Edit Link” window will open, but if I paste in the desired link, and check “Open link in a new window/tab”, when I then click the “Add Link” button at lower right, the screen pauses a moment and then reverts back to the list of posts, and my work (including the new link) is un-saved, hence unable to be “Updated.”

    Finally, the links in my post where I have copied and pasted raw URLs into the text show as clickable links on the site, but when I am logged in and editing the post, they show as plain text and do not reveal any live link for editing in the Visual editor.

    Oh, also, the links in MikeDariano’s post at


    are not clicking through for me!

    Obviously, I will be madly grateful for any help from any advisors.

    The blog I need help with is brooklynmusic.wordpress.com.



    Hi there,
    It sounds like you need Staff assistance so I tagged this thread for their attention. Please subscribe to it so you are notified when they respond.


    I have the same problem media link doesn’t work , I can;t add any posts



    Hi Paul,

    I have created a draft post on your blog, here: https://brooklynmusic.wordpress.com/wp-admin/post.php?post=1677&action=edit&message=10

    What version of Mac are you on? Can you disable any browser extensions and clear your cache? Here is more information about how to do that:

    What tab of the post editor are you using? The “visual” or “text”?

    Thanks for any clarification you can provide!


    Thanks so much for your work on this issuer, ZR.
    I’m on various workstations, laptops, desktops, so I’m trying to be very vigilant about always logging out when done, and following all instructions: https log-in, clear cache, etc.
    I’m running OS10.7.5 on an Intel Core i-Mac, browser is Firefox 18. I use the “Visual” editor.
    I saw your radishes image on the test post (!) but now, am unable even to edit pre-existing posts. That is, when I log in as admin and go to the dashboard and open a post from my list to edit, the window where the post appears for editing is blank.
    Same thing when I look at the blog and click “Edit this” over one of the posts.



    Hi Paul,

    That is really, really interesting. I know it’s terribly inconvenient for you, and I sincerely apologize.

    I am able to see (and experience) exactly what you describe in the post you linked to. We’re going to do some examination of that post, so could you please not touch the post itself for a while? Should be simple enough, considering it’s not behaving for you :)

    Again, I apologize, and hopefully we’ll know more soon.


    Thanks very much!
    In addition to the issues above, I see that if I attempt to click on “Add a Poll” button it won’t respond, but the “Add a custom form” button





    Hi Paul,

    Great news – we’ve done a little work behind the scenes, and you shouldn’t have any trouble clicking those buttons/tabs now!

    Could you please give it a try and see how you do?

    I can help you pull up a revision of the post here:

    So that you can see something besides the blank editor :) Just let me know if you need a hand with that.

    If you’d like to read more about the polls (not that you asked, per se), here’s some more info:

    So, let me know if you’re still having any lingering issues that need sorting out, and if you would like help selecting a revision edition for that post.



    to all Happiness Engineers, and to ZandyRing:
    my heartfelt thanks for your persistence and your work in resolving these issues.

    Everything seems to be working A-OK.


    Oops. I’m still having issues with posts being invisible in “Visual” editing.
    I copied the existing post at

    and pasted it into a new post, and did all my work with click-able links (thank you, again!) but after I pressed “update” to save the draft, before going to add the images. It saved and now the editing screen is blank.

    Also when I try and edit the original post (URL above). Please don’t mark the thread “resolved” just yet.



    Hi Paul,

    Well I’m glad we got some of your issues cleared up! So I made a draft post (then published it as “private” post). I wrote down my process in the body of the post:

    Could you try to edit the post and see what happens?

    Sorry for the on-going inconvenience!


    When I click on the draft that you made I can see the text in Visual editing, and I can add an image, and add a link. But it’s still impossible to see and edit


    of the older posts that were already published, if I look at the list of All Posts, and then click “Edit” below the title of one of the posts.

    Does this mean that none of my existing posts can ever be edited unless I compose it again from scratch and work on it as a “draft” ?



    Hi there,

    No, not necessarily. Let’s use this post as an example for this:

    If you look below the post area, you can see a Revisions section; if you click on the bottom-most revision, you see this:

    Notice that you can compare recent revisions and restore a previous revision. You can restore one of the previous revisions and see if then you can edit as usual.

    You may indeed need to repeat this revision restoration for any post you want to edit as you look back if it has vanished from the editor for you, I’m afraid.

    Can you let me know how you make out?


    OK, a little progress but not “resolved”:
    I can edit somewhat, the way you describe ( searching through prior revisions, choosing one that looks OK and clicking “restore”). This seems to work in Chrome. But if I do it in Firefox, and then click the blue “Update” button at the right of the editing screen, the Visual editing screen goes blank, and the revisions are lost.

    In any case, I can no longer use the “Edit This” button that appears in the dateline seen above every post when I am viewing the site logged in as admin.

    It’s very disappointing. If you or any other Happiness Engineers are still looking at this issue, I would like to point out that I am also seeing tomorrow’s date in the list of revisions, which is baffling. I just uploaded an example of this in the screen grab at:

    Thanks as always, for any time you are able to devote on this. Is it a template issue? Is it possible to cure all these ills by simply switching to a different design?


    No it’s a disaster, Zan. I just restored a desirable revision in Chrome, did a couple of edits, pressed “Update” and it went white and I lost the revision.



    I’m so sorry you’re still having trouble.

    I would like to point out that I am also seeing tomorrow’s date in the list of revisions, which is baffling.

    Your time zone is currently set to UTC (aka GMT) which probably accounts for this. You can adjust this under Settings > General. Just select the correct time zone and save your settings.

    I’m going to bring your newest observations back to our developers so they can continue to investigate and try to poinpoint what’s going wrong. Thank you for reporting in detail what you’re doing – the discovery of a difference between Chrome and Firefox is potentially helpful. We don’t think it’s a theme issue so switching themes shouldn’t make a difference.

    Until this is sorted out, you may want to compose and save your drafts in an offline editor such as TextEdit. I realize how agonizing it is to lose a draft and really apologize for the ongoing problems.



    In any case, I can no longer use the “Edit This” button that appears in the dateline seen above every post when I am viewing the site logged in as admin.

    Could you please describe exactly happens when you click “Edit This”? Is it the same in Firefox and Chrome? I was able to click “Edit This” without any problems while logged in on your account, so it would be helpful to know what you’re seeing. Could you try turning off any browser extensions or add-ons ans see if that makes any difference?


    Dear Kathryn and other wp engineers.

    OK, what happens seems a little arbitrary. In FF18 I find various posts that I can view in Visual, simply by clicking “Edit This”, and others that I cannot. Don’t seem to see a pattern. For example, it doesn’t have to do with the relative age of a post, or whether there’s an autosave version of the post, or not, according to the red-font note at the top of the dashboard page).

    I have tried disabling all add-ons in FF.

    It’s very kind of you to take time looking at this anomaly. I’m going to list exhaustively the steps I took to test the way my blog is misbehaving under various conditions (and browsers). Sorry to be boring.

    How issues arise in editing:

    I. Firefox: Log-in as admin. Go through dashboard to list of posts.

    1. First item in list is “Draft post to check link function”. I click on the title in that dashboard list (not “Edit). Post opens for editing and i am able to see it and edit successfully. I press “Update” and then “Preview” and everything is fine.

    I leave the Dashboard (still logged-in) and view the post as it appears on the blog (not preview). Click “Edit this” in the dateline, and it opens successfully. Edit it, and update, no problem.

    2. Second item in list is “Draft to check post disappearing issue”. It also works fine both ways (open from list and edit, or click “Edit this” in the dateline, from the blog).

    3. Third item in list is “The symphony flashmob videos: Spain and Denmark II”. I click the title and it opens to a blank Visual edit screen (i.e., no post content). If I click “Update” at this point, I will create a blank post on the blog.

    4. So I click “Back” on the browser (FF18) and click on “Edit” (below the title, in the list of posts) and same result — blank post in the Visual editor.

    5. Now, I click “Back” on the browser (FF18) again. Go to the blog and try clicking “Edit This” in the dateline on the blog post (which is still looking OK, because I haven’t “Updated” any of the blank pages that came up in Visual editor, above). The post comes up blank in the Visual editor.

    6. I go back to the Dashboard list of posts and try the fourth item in the list: “Draft post to test add media button”. I click the title in the list and it comes up blank.

    7. I repeat step #4 (back on browser, etc.) and have the same result: blank window.

    8. I go back to the Dashboard list of posts, and scroll down to choose an earlier revision and I restore it, so I can see some content in the Visual edit window. I press “Publish” and it publishes successfully. I press “Edit this” in the dateline on the post and the screen opens up, Visual edit is working fine.

    9. Now, I go up and down in my list of posts (in Dashboard). One after another, if I click on the title of a post that looks perfectly good on my blog, it opens with a blank Visual editor. Same if I click “Edit This” in the dateline on the blog.

    This means that any older post I want to revise or update will only be accessible if I go through the steps to choose a revision from the list of past versions and then restore it. And on some of these, the “restored” version is coming up blank as well.

    (now I close FF 18 and move on to check in Chrome browser)

    Step 10. In Chrome, I repeat step 3 from above, and same result: blank Visual editor window.

    11. Repeat step 4 from above, and same result.

    12. Repeat step 5 from above, and same result. :(

    13. Now, I try accessing older posts either by clicking “Edit This” in the datelines where the post appears correctly on the blog and get the blank Visual edit window.

    14. Start grabbing older posts from the Dashboard list of posts and clicking on the title, and each one seems to come up blank.

    (now I close Chrome and try same steps in Safari. Same results.)



    Thank you for the detailed steps, and I’m very sorry about the continued inconvenience. The information you provided will be useful to them I’m sure. We’ll get back to you if we need anything else.

The topic ‘Unable to upload media to a new post, unable to edit links’ is closed to new replies.