Updating email server addresses

  • Author
    Posts
  • #1069007

    theautophile
    Member

    Hi, hope someone can tell me where I’m going wrong!

    I added my domain name to my blog and during that process I was asked if I wanted to move my email too, which I clicked yes to before realising WordPress doesn’t actually host email itself.

    I am now trying to add mx records which I obtained from my email host provider, but the ‘A’ record is being rejected. Dunno if this is a simple syntax issue or something else altogether.

    The 2 records I’ve been given are;

    A mail.xdconsulting.eu 85.10.245.42
    MX 0 mail.xdconsulting.eu

    The first (A) record is being rejected by WordPress, can anyone tell me why?

    Many thanks….

    The blog I need help with is xdconsulting.eu.

    #1069105

    auxclass
    Member

    Maybe this will help: http://en.support.wordpress.com/domains/add-email/

    These are the record types that made my email work
    A mail 255.255.255.255
    MX 10 mail.my-domain.com.

    Note the full stop (period) after the com

    I will also flag this for the staff and maybe they can help you with the formatting more – when I moved I got the info from my old host that I kept the email with but the formatting was a bit different here

    #1069106

    kardotim
    Member

    Please try to add these dns records in your Custom DNS field at ‘Store’ -> ‘Domains’ -> ‘Edit DNS’ in your blog’s dashboard.

    A mail 85.10.245.42
    MX 0 mail.xdconsulting.eu.
    #1069108

    theautophile
    Member

    Thanks for your help guys! I’ve added those 2 records in the ‘Edit DNS’ section and both seem to have been accepted. There is still a record which seems to be there by default; MX 0 xdconsulting.eu.
    Should this always remain?

    #1069111

    kardotim
    Member

    You can remove that record.

    #1069115

    auxclass
    Member

    @kardotim – I am curious why
    MX 0 mail.xdconsulting.eu.
    and not:
    MX 10 mail.xdconsulting.eu.

    thanks

    #1069116

    kardotim
    Member

    He was referring to 0 xdconsulting.eu not 0 mail.xdconsulting.eu . The MX record has to have a subdomain because that links to the IP address of their TuCows domain/mail provider.

    The MX preference number only matters when there are multiple MX records. Either 0 or 10 is fine.

    #1069117

    theautophile
    Member

    Brilliant, thanks again,will let you know what happens when/if email comes back up!

    #1069118

    auxclass
    Member

    Thanks –

The topic ‘Updating email server addresses’ is closed to new replies.