Uploaded images disappear when blog draft is saved

  • Author
  • #1015880


    I uploaded pictures, they appear in both media library and in the post I am trying to write – but when I hit “Save Draft” they disappear while text – if there is text – remains in place. Any idea what’s the matter?
    Blog url: http://empireoflights.wordpress.com/

    The blog I need help with is empireoflights.com.



    I’m having the same problem. Hitting the “update” button after I’ve added some pictures to my gallery, all pictures have didappeared. They’re still in the media library, but not on the published page. Maybe wordpress is too difficult for me… very frustrating!



    Thank you for commenting! So it may be a WordPress problem rather than hardware/software problems at our end?

    I tried again today – same picture (well, absence of picture) – which is kind of annoying for someone running a photo blog.


    Hi tomasc85 and indiedyer,

    I’m sorry for the inconvenience, and I’ll be happy to take a closer look.

    If you haven’t tried this yet, can you let me know if you get the same result when using Google Chrome?

    @tomasc85: Can you let me know if you get the same result when trying Firefox in Safe Mode?



    Hi bryanvillarin,
    thanks for looking at this.

    I don’t want to use Chrome.

    Yesterday, I got around the problem by deleting all unattached images I’d previously uploaded to the media library. Instead of trying to attach photos from the media libray, I created a new page and uploaded the photos again.

    I will not try to add or change any existing posts or pages ever again. That’s when the images disappear and have to be re-attached. I just have no time for this.

    It seems inconceivable that it’s not possible to upload lots of images to the media library in advance and then pick them from there at any time to furnish pages and posts.

    But maybe it’s just that I haven’t understood the tech side of wordpress yet.



    Hi Bryan,

    thanks for looking into this. I started Firefox in Safe Mode (as suggested in the other thread) – and it works. People should be able to see the test pictures in the latest post now. I uploaded from the Media Library.

    So we’ll only have to find a way to make things work in “normal” mode.

    Sorry if I do not respond immediately … time zones …




    @indiedyer — Which browser are you using?

    To narrow a browser–specific issue, can you try an alternate browser to see if you get the same result?


    It seems inconceivable that it’s not possible to upload lots of images to the media library in advance and then pick them from there at any time to furnish pages and posts.

    It is possible. When you click the Add Media button while editing a post/page, you can click the Media Library tab in the window that pops up.

    @tobias — Great! I’d suggest disabling all Firefox add-ons, then re-enabling them one at a time (whilst refreshing the Edit Post screen in between).




    Hi there,

    did not get around to trying disabling the add-ons and then re-enabling them (I’ll do that tomorrow morning, it’s now 1120 hrs here). But I can report that the problem does not seem to occur with Safari 5.1.7.

    Does that help any?

    Good night!



    I can report that the problem does not seem to occur with Safari 5.1.7.

    Does that help any?

    Absolutely. Thanks for the update, Tobias. Sleep well! :-)



    Hi all,

    here is some narrowing down of the problem: With Firefox 15.0.1., I use an add-on called Ghostery to block trackers and maintain some privacy while I am online.

    Whenever I open my dashboard, Ghostery finds five (!) trackers trying to look over my shoulder, gathering insights:

    – Google Analytics
    – KissMetrics
    – New Relic
    – Quantcast
    – WordPress Stats

    Blocking New Relic does not cause any problems while blocking any one of the other four lets the pictures disappear, as described by several users above.

    Blocking the trackers also causes problems with the “inifinite scrolling” function.

    As far as I understand it now, blogging with WordPress comes at a price: You have to give up part of your privacy to make it a worth while experience.

    This does not feel right to me (correct me if I am wrong), so the question is if there is any solution to this other than switching off Ghostery.





    Update: I had to pause blocking the trachers by Ghostery completely to be able to finish next Saturday’s post. This is not fun. T.


    Hi Tobias,

    I did some testing with Firefox 15.0.1, with only the Ghostery 2.8.3 add-on activated, but images inserted into my post draft (from the Media Library) were displayed properly. Here were my steps:

    1. (Firefox) In Tools > Clear Recent History, with Cookies, Cache, and History checked, I clicked “Clear Now”.
    2. (Ghostery) In Options > Blocking Options, for the 3pes tab, I clicked Select All, then Save, and repeated the process in the Cookies tab. So, now I see “1119 total 3pes (1119 blocked)” and “566 total cookies (566 blocked)”.
    3. I logged into my WordPress.com blog dashboard, and Ghostery shows that Quantcast and “WordPress Stats” are blocked. Capital P! (screenshot)
    4. On the Add New Post screen, the same two are blocked.
    5. On the Edit Post screen, I inserted an image from my Media Library, and the image displays in my visual editor. For good measure, I switched to the text editor, saved the post draft, and after it refreshed the page, switching to the visual editor still displays the image I inserted.

    Can you try creating a new Firefox profile, then follow the above steps to see if you get the same result?



    Hi Bryan,

    I appreciate the support. Ghostery 2.8.3. seemingly isn’t available from http://www.ghostery.com/download, for whatever reasons. I’m on 2.8.2. However, the numbers of blocked 3pes and cookies are the same (1119 and 566).

    I did not yet create a new Firefox profile (frankly, I have yet to find out if I want to do that).

    And the whole thing does not work: Ghostery keeps finding four trackers and blocking them seems to cause the problem. The workaround is whitelisting WordPress and the Empire of Lights – but that’s not yet a satisfactory solution.

    Best, Tobias



    Hi all,

    after proceeding exactly the way Bryan dscribed, things seem to work just fine. I’ve also found and installed the Ghostery 2.8.3. update.




    Cheers Tobias. :-)

The topic ‘Uploaded images disappear when blog draft is saved’ is closed to new replies.