Need help? Check out our Support site, then

Uploading images

  1. I've just started up a WordPress blog and I'm having trouble uploading images into my posts. I can insert an image where it links to an image with a URL, but I can't upload an image from my computer because the Browse/Upload option described in the Help pages doesn't appear when I'm editing. Where is it, or what do I need to do to make it appear?

  2. What browser, browser version and OS are you using? The upload box should be right underneath the box where you write your post.

    Try clearing out your browser's cache and doing a forced reload of the page to see if that helps.

  3. Mozilla Firefox 1.5.09, Windows XP. I've tried clearing the cache and reloading and nothing changes. Things are no different with Explorer (version 6).

    I'm mystified.

  4. I'm still lost. Looking through the WordPress documentation, I see that there is an 'allow file uploads' option under Administration Panel / Options / Miscellaneous. But when I go looking for this I fin that there is no Miscellaneous section among the Options. Have I got some rogue version which isn't going to allow me to upload images?

    Still mystified.

  5. Hi there,
    This thread will introduce you to the basic wordpress resources that you can use to answer questions

    Comment edited.

    Both of the browsers you have named have known issues. IE7 and Firefox work very well with wordpress.

  6. TT, they're not seeing the uploader. They don't need help with uploading. They're missing the uploader.

    Only thing I can think of is to make sure that javascript is turned on and you're got flash installed.

    You're looking at the docs for the regular version of WordPress. We're running WordPress multiuser here at

    I would suggest sending in a feedback and asking if staff has any ideas on the subject. I'm at a loss.

  7. OOPS! I apologize for being off-base ... and confused ...

  8. Hi - I'm having the same issue - it's driving me NUTS!!! i cannot see the uploader bit to put the pics in underneath the posting bit where you do your writing. i've got ie7

  9. I would suggest sending in a feedback and asking if staff has any ideas on the subject. I'm at a loss.

  10. One quick way to find out if it is security on either a browser or your local firewall (even windows firewall with XP) is to install something like Firefox with the default installation. If you check your upload with that browser and it is there, you can assume it would be a security setting in IE and if not, it might be some security application on your computer playing around with you!

    Something to think about anyways.


  11. I've got another Contributor to the blog who has reported the same problem. I don't know what browser or OS he's using, but maybe that's not the issue? Anyway, I've submitted feedback and will report back if I hear anything.

    Thanks to everyone for giving the issue some thought.

  12. I've partially solved my problem by upgrading to Firefox 2.0. Magically the Upload option now appears under Write Post, though not under Write Page. So I'm mostly OK, though I don't know yet why the problem occured in the first place. It seems to be something to do with iframes, as I get a message on Write Page where the Upload bit should being which says something like "This page require iframe support". However, I could find nothing in the Browser options that covered this. So a solution of sorts, but not quite a problem answered.

  13. Strange as iframes are supported in firefox 2.0. I'm hoping someone else can take a stab at this as I'm leaving for the night. Already late. If no one does, I'll hit it tomorrow for you.

  14. I wrote too soon. The Upload feature has just disappeared from Write posts, and I am told "this feature requires iframe support" once more.

    Good night.

  15. Since you're uploading images rather than anything more complicated, I'd try an offsite photo hosting service like Photobucket or Flickr. If you never get that Upload box to show again, it won't matter. I've done some instructions for using Photobucket here:

  16. That really doesn't solve the issue though.

    Here's a thread on the subject. You may want to review it and see if that helps at all.

  17. Thanks for that last thread - it seems to have done the trick. My situation was the same as the person on that thread - unable to upload images despite using latest version of Firefox, though the crucial extra bit was McAfee Security settings. I followed the advice to change my McAfee settings (under Privacy Service) to allow ads and to include WordPress under Allowed sites, and now I get the Upload option for both Posts and Pages. So problem resolved, and thanks to everyone for your help, but this seems like a significant failing for WordPress. Clearly several others have had the same problem, and it ought not to be such a problem to have a simple upload option available to all.

  18. I would suggest sending in a feedback on monday and making this suggestion. That way, staff will be sure to see it.

  19. glad you figured it out.

  20. this seems like a significant failing for WordPress

    More like a false positive upon McAfee's end. Wouldn't be the first time. They were calling a version of phpNuke a virus a few years back.

  21. New here also and was missing the image uploader on the Write page. After trying a few different browsers, clearing my cache, and jacking around with McAfee, Adaware, and Spybot, I too discovered repeatedly pressing Ctrl+F5 did the trick. After two or three tries the uploader popped right up..


Topic Closed

This topic has been closed to new replies.

About this Topic