Need help? Check out our Support site, then

Uploading media from iPad

  1. Hi there,

    I'm trying to blog using my iPad, and have tried to upload media from the photos section. Unfortunately it won't let me. On the WordPress app I get an error message bad login/pass combination, and on the website version it won't allow me to upload from the iPad. I've searched the FAQs and can't find an answer. I've relogged in, but that hasn't worked.

    Any ideas?

    Blog url:

  2. This usually means that the credentials on store for that particular blog are outdated. To resolve this, try the following:

    1. Start the app if it's not running already.
    2. Go to the Blogs list. (The first screen you get to if you start the app.)
    3. Tap the Edit button in the upper right corner of the screen.
    4. Tap the blog title of the blog you're having trouble with.
    5. In the blog settings screen that appears, double check the username and password, update if needed.

    Another reason for this happening could be insufficient user privilegies. Make sure that the user you're using the app with has the ability to post new posts in the web admin, too.

    Let me know if this works, if not we'll have to dig deeper.

  3. Hi, thanks for your reply. I checked username and password, then I checked on the web for user permissions. It's only me that posts on my blog and the role is listed as administrator. I then tried to post a picture from my iPad and still got the same bad login/pass combination message.


  4. If you go to the Settings app and scroll down to the WordPress app settings, what is the version number?

    If you're running a version older than 2.8.3 I'd recommend upgrading. Also, is your blog hosted here at or is it self-hosted?

  5. Hi, it's version 2.8.3 and the blog is hosted at


  6. Looks like we have a bug on our hands, most likely it's a migration problem that occurs when upgrading from an older version of the app. A similar issue was noted by another user.

    We'll be working on a fix for the next version of WordPress for iOS, due in a few weeks. You can track the process here:

    As a simple work-around, you can re-add the blog which saves the credentials and you should be able to start posting again. Note: you might lose any local drafts if you follow the guide below.

    1. Open the WordPress app.
    2. Go to the Blogs list and tap Edit, and remove the troublesome blog from the app temporarily. (You can also do this by swiping over the blog title and pressing Delete.)
    3. Re-add the blog by tapping the + icon and following the on-screen set up instructions.
  7. Thanks very much.


Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.