Need help? Check out our Support site, then

Uploading photos

  1. Hi, for the past 24 hours I've been having problems uploading pictures to my blog. When I click the icon (add an image), the next page freezes and I never get the box to insert the info (url, size etc.). It's weird because it doesn't seem to be a problem with my connection (low speed, for instance) because all the other internet pages are opening ok and quickly. Is anyone else experiencing the same problem? I know you had a problem fixed a couple of days ago, so should I be a bit patient or is there anything I can do to try and sort things out? Thanks!

  2. Please give us a link to your blog so that we can see how to help you.

  3. Sorry, I forgot that part... :-)


  4. Hi I can't seem to upload photos either, I select a photo from my pictures file and the thumbnail pic appears but when I click on upload it just freezes halfway through trying to connect to loading and nothing more happens. Have tried to do this on my personal page and to create my own header? Any tips? I am working on a Mac with a 4.11 op system. I'm new to all this so do I need to give you a link to my blog?

  5. exquisiteflower

    Hi, i cant upload anymore photos from URL link.I didnt have any problem until the upgrade of wordpress 2.7.Please help.

  6. Please either link your name to your blog (under Settings General) or give us a direct link t the blog, starting with http.

  7. I am able to upload photos still (uploading from a URL is on a separate tab now), however, the images no longer upload at full size, which makes them useless as free downloads (I host a blog for free stock images).

    Now I have to host the original size elsewhere and upload a small image to the blog, adding a link to download it from. It's a pain when using a url to add an image you can't select a display size - it automatically loads (or tries) the full size image. This makes double the work.

    Man, I sure wish they'd leave my dashboard alone too :)


  8. Do you mean it doesn't show up full size, or it doesn't upload at full size (and then shrink it down later)? Because those are different.

  9. Hi,

    I have the same problem like graceystinson. It doesn't matter if I use the flash uploader or the browser uploader.

    This article is my problem:

    A few days before there were no problmems with klicking the photos to have the original size:

    So I think it's a problem of the new version. I didn't change the theme.

    I think the upload is okay, because if I go to "media" and klick on the photos, it's the original size. But I can't click in the article on the photos to show the original size.

    Or maybe my update to Firefox 3.0.4 could be the reason?

    I hope you can help me. Thanks in advance. And please excuse my bad English. :-)

    Best regards

  10. This has been answered repeatedly. After uploading, you need to click "File URL" before inserting the image to the posts. From then on, the uploader will remember your preference.

    For the images you have already uploaded, go to the visual post editor, cick on the image, click the mountain icon, click "Link to image", click Update.

  11. @raincoaster

    it doesn't upload the full size. I uploaded the image in my current post (Corner Fireplace) at it's full size using the image function. It's full size is 2667 pixels by 2000 pixels; when it completed the upload it showed only a pixel size of something like 725 pixels (I forget the other dimension); the image in the uploader showed the original size as the reduced (725) rather than 2667. The image entered into the post was smaller (I usually select something around 400 or less as the post size). Clicking on the image in the post only brought up the 725 pixel image, not the original 2667 pixels.

    I deleted everything. Then I created smaller images (475 pixels) of the originals and loaded those into the post. The original size image I uploaded to a filehost and used the image link in the media file to make them downloadable at full size.

    I didn't used to have to do this.

    I will admit - this is the first time I've posted to the updated WP version, so I may be doing something wrong, but I pretty well know how to handle the media uploader since my entire blog is images.

    I also have a blog hosted from my own site and haven't upgraded it - everything still works the same on that, though I know it's different than the .com set up.

  12. exquisiteflower

    I did tried click "Link Image" after paste the URL address link.

    But after clicking it "Insert to post",it just didnt go anyway.
    And the "Insert to post button becomes unshade.

  13. @panaghiotisadam: Thanks! That's great!


    From previous articles I know that including thumb nails to articles enables spectators to click on the image in order to enlarge. However, newly added thumb nails keep small whereas thumb nails in older articles still work well.

    May I please ask for assistance where I can change this on the new dashboard version.

    Any advice is highly appreciated.

    Many thanks in advance.

  15. @hubschrauber: Read my previous post above.

  16. I'm having the same problem now. Link to the URL, uploaded "full size" and yet can only open a thumbnail in these newly uploaded photos. Previously uploaded photos open in another window at full size rather than just another thumbnail.


  17. @hubschrauber
    You haven't inserted any links with the images. Before clicking Insert into Post, click the File URL button to set the Link URL. After you do this once, the setting will be remembered for next time.

  18. When I insert a thumbnail image, it will open full sized in the same window when it's clicked.
    I I want it to open in a new window, I have to go to Advanced Settings (the mountain picture), and select "open in new window."
    I mostly use Firefox. Perhaps I've got some browser setting that need to be changed?

  19. I do the same thing, 1tess

  20. I've also just uploaded the same picture 3 times thinking it was something I'd done wrong on my blog ( No progress bar as the picture uploads (very confusing; made me think I had a sluggish connection) then it refused to open in a new window as it used to. I'm sure I'll get used to it, but it seems to make posting slower and tricker, which I'm sure wasn't the intention behind the move to 2.7.

    As for the small "Quick Post" box on the Dashboard, I definitely preferred the larger version, but then since I'm mostly posting photos, keyhole surgery isn't really the best way for me to operate ;)

  21. cbramhall
    You don't have to use the small "Quick Post" box. The regular version is found by clicking the tack-icon on your dashboard:
    Posts -> Add New

    You might try clearing your browser cache and cookies. The upload problem you describe does not sound as if its related to the upgrade. If that does not help, then contact support.

  22. exquisiteflower

    Previously, after i cut and paste the link address at "Image URL" column,it will give a green tick symbol meaning to say its alrite.Previously, i would just click "Insert into Post" button(without clicking "Link Image")and the screen will refresh and brings me back to my edit post.

    But after the upgrading, once i click the "Insert into post" button.(even after i click "Link to Image", (which i notice no difference code from Image URL)

    The screen wont bring me back to my edited post.And the green symbol tick mark next to Image URL,it seems to be gone.

    I still cant solved this issue.

  23. I've also been experiencing problems when using the add image button to upload PDFs to my blog entries. This has always worked fine before and worked once on Friday afternoon and now will only insert the name of the file with no active link. I've tried about 12 times as have some of my colleagues and we are all getting the same problem. We've also tried to add the file via the add media button, and it won't work that way either - just the file name and no active link.


    Blog name:


    PDFs work the same as images, work the same as .doc files.

  25. Thanks. Ensuring that there's actual content in the URL file box solved all my problems. It had obviously been doing it automatically before and I hadn't noticed when it didn't do it! All sorted now :o)

  26. mrwilliamsburg

    I'm having the same issue as purplepaula. When I upload a pdf file it only inserts the name of the file but not an active link. I have done this hundreds of times before in the last year...
    Here is an example

    Help !

  27. mrwilliamsburg,
    Take a peek at raincoaster's comment above.

  28. @ panaghiotisadam and @ mtdewvirus

    Many thanks for your patience answering my question. Of course, I got it after reading your advice carefully.

    Falls ich nun vielleicht einem anderen deutschsprachigen Hilfesuchenden bei seinem Problem mit der Darstellung von Vorschaubildern behilflich sein kann - bitte gerne!

  29. kamaraskreations

    I have tried several times over several days to upload an image from the browse file tab, but each time I try, I totally lose my internet connection. I am working from my wireless laptop with a Belkin router. Each time this happened, I had to go downstairs and re-set the router. I read the comment about clicking the URL file after uploading, but I can't even get that far. As soon as I click the upload icon then browse, I find my image in my documents, click insert, then my internet goes out during the upload. Any suggestions for me? My blog is at
    Thanks in advance for your assistance.

  30. I, too, am having trouble uploading photos today.

    WordPress seems to be uploading the photo but every time the upload gets interrupted due to HTTP error. Any thoughts on that? The problems stays the same even if I refresh the page.

Topic Closed

This topic has been closed to new replies.

About this Topic