Vanishing Images

  • Author
    Posts
  • #387157

    raincoaster
    Member

    I am wondering if it has something to do with using the Caption code vs not using it. I generally strip it out, and ALWAYS on a blog with Custom CSS. I’ve noticed it has some weirdly random alignment control effect you can’t override most of the time until you strip it out.

    #387158

    With the post open in the editor, edit the image, go to the advanced tab, remove the position:absolute; and then at the very bottom of that window click “save changes.”

    Delete the image from the post and reinsert it, click the update post button and then after it saves, check the HTML.

    The thing is, the position:absolute; if it were to be used, should have been in the img src section of the code, not in the href section.

    I cannot reproduce the error so I have to believe it is something on your end.

    #387167

    churchmouse
    Member

    I had the same problem yesterday with 3 images. I ended up making one of them smaller. That seemed to fix the problem.

    #387198

    dmxgraphic
    Member

    With the post open in the editor, edit the image, go to the advanced tab, remove the position:absolute; and then at the very bottom of that window click “save changes.”

    Delete the image from the post and reinsert it, click the update post button and then after it saves, check the HTML.
    —–

    OK. This works fine. The HTML is fine in the post editor and in the post itself..

    BUT in the editor if I switch from HTML to visual mode and back to HTML the code has reappeared. The effect of this is once again to make the image overlay the text in the editor and if I update the page the code is included.

    Note that the position:absolute code is always present in the image editor advanced tab under Advanced Link Settings/Styles regardless of whether I have deleted it or not.

    #387199

    dmxgraphic
    Member

    So the workaround is to be aware that the offending code will reappear during editing and to manually remove the code before updating the post.

    #387201

    vikasjnu
    Member

    It has happened briefly with me too. But clearing the browser cache had helped.

    #387203

    vertebrado
    Member

    Today,images are loading fine. No problem anymore.

    #387214

    dmxgraphic
    Member

    I tested this problem several times since my last post. It may be resolved. The ‘position:absolute’ code is no longer being inserted into the ‘a href’ tag and no longer appears in the image editor advanced tab under Advanced Link Settings/Styles.

    #387250

    Let me preface my comments with the fact that I know nothing about coding!

    I have posted a story today http://robertakedzierski.wordpress.com/ entitled Lovely Lavena on Lake Lugano. It’s basically a picture story containing 22 images (each max. 100K).

    I can see it perfectly, using Firefox 3.0.13 on Mac 10.5. On my other computer, though, which uses Mac 10.3.9 and a lesser-quality Firefox, I can read the text and see blanks for the images. I tried using Safari and there was no improvement.

    It could be that the way I created this file is a little crazy. (Don’t ask.) I downloaded the pix to iPhoto, I then created the document with long captions using the email facility, which I sent to myself on gmail. And it looked fine. I then loaded that into Google Docs. Which also looked fine. I then posted it to a web page and also used the Google Docs facility to upload it to WordPress.

    That said, if I can see it — and it looks great, even tho I say so myself — why can someone else, attempting to access it on another computer be unable to?

    Pls advise.

    Thx

    PS The reason I tried using the google docs route etc, was because I had uploaded some images previously to my husband’s blog http://mikesnyder.wordpress.com/ and although I could (and can) see all 44, a friend reported he could see only one.

    Question: Is WP not suited to images? to images of this sort? should I go elsewhere? Thx

    #387251

    This is the “URL” of the first image I see in the latest post: https://mail.google.com/mail/?ui=2&ik=5314dbae22&view=att&th=1231e9acf218ff7f&attid=0.11&disp=emb&realattid=0.1.2&zw

    That will never work since you are asking wordpress to access your gmail account to get the image.

    You need to upload the image directly to your media library here, or to some sort of file sharing service on the internet (and why do that when you have 3gb of upload space here for free?

    #387252

    Sorry, forgot to add the URL for the story as it appears as a Google web-page:

    http://docs.google.com/View?id=dn6hgs7_99mznpjtf8

    Thx again.

    #387253

    The images are still linked to your gmail account, and wordpress cannot access those. This is the link to the first image in the docs.google page linked above: https://mail.google.com/mail/?ui=2&ik=5314dbae22&view=att&th=1231e9acf218ff7f&attid=0.11&disp=emb&realattid=0.1.2&zw which is the same.

    You CANNOT link to images that are in your gmail account.

    #387254

    This is what I see when I go to that google docs page: http://opposablethumbz.wordpress.com/files/2009/08/docs.png .

    Why? Because I don’t have your username and password to your google account.

    #387255

    izaakmak
    Member

    This is for the first two queries in this thread (not you TSP). I re-post a lot of funny emails sent to my gmail account, and it can be a chore to duplicate the formatting of the original email. Early on I tried pasting directly from the open email into the visual post editor. This seemed to save me the trouble of uploading the images to WP, but I discovered later that they had disappeared from my post once I deleted the original email! I have no idea what would happen if I hadn’t deleted the email, I simply don’t try to shortcut the process any more.

The topic ‘Vanishing Images’ is closed to new replies.