very slow to upload

  • Author
  • #1057694

    I’ve returned to my blog after a sabbatical of a couple of years.

    New postings refuse to upload. The mill wheel grinds away with the notation “publishing” but nothing happens. In the end I give up.

    I’ve tried posting a short blog plus a jpeg image reduced to about 380K. Then I tried deleting the image and just sending the blog, but still nothing happened. Nothing is published when I click the button.

    I work my blog in Word and then copy and paste the text into the blog, making any spacing corrections in situ. This has always worked in the past.

    Is WordPress particularly slow these days? Or has something changed while my back has been turned? Advice would be appreciated. Thanks.

    The blog I need help with is


    Perhaps I should add that I’ve checked my internet connection and that is running at normal speed so my text posts at least should upload within a few seconds rather than the 10 minutes plus at which I abandon hope.


    Update: publishing still refuses to cooperate but I’ve found that Quickpublish works instantly. So what’s wrong WordPress?


    Update: I’ve found that I can’t publish a new posting from the ‘write a new post’ page, but somehow I found another way to it and that seems to work. Unfortunately I found the other way by accident! Now I need to find it a second time! The original page still refuses to publish (or upload images). What’s going on here, WordPress?



    Copy-and-paste from MS Word is notoriously error-prone because of unwanted control codes which get copied without your knowledge from Word into your WordPress site. It’s much safer to compose your text in Notepad then copy-and-paste from there into your WordPress site. (Or even copy-and-paste from Word into Notepad if you must, then copy-and-paste from Notepad into WordPress.)


    hi eridout and thanks. I’ve found Word not too bad but I agree some editing and work is required after posting. However, I’ve tried typing text directly into WordPress and still ‘publish’ refuses to work. So I can’t fathom what is wrong.


    I had the same issue. What worked was to go under my profile dropdown menu and then the “new post” in the area the dashboard link is. Posting from the front end caused the problem.


    Thanks apggregcrawford – I seem to be having problems with the whole site now. My Profile has disappeared and all I seem to be able to reach is short-form posting screen giving me the title bar but nothing else!! Front end posting has gone completely. I think maybe I’ll move to Blogger – it’ll be quicker. Thanks anyway.



    There’s an issue with creating posts on the front page of and with editing posts created there that will not be fixed until the next upgrade. Do not create posts here >!/post/

    Instead I recommend that you ONLY create posts here > Dashboard > Posts > All Posts > Add New

    If you are not running one of the browsers and versions listed at please try upgrading or switching first.

    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see >

    If you are, please do these four things:

    1. Try clearing your browser’s cache

    2. Make sure that you have third-party cookies enabled

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS:

    If you are not successful let us know which browser (and version of it) you’re using and post any error reports you get.


    Thanks timethief – I managed to reach a write post screen using Opera but it’s not as efficient or effective as before. I’m running IE8 which is the latest for XP according to Microsoft. I’ll have a go at the four-point plan and see if that resolves outstanding issues.

    Why do these people try to mend things that aren’t broken?



    I’m running IE8 which is the latest for XP according to Microsoft.

    IE10 was released for Windows 8 users on October 26th. IE9 is most current browser version for those who don’t run Windows XP. Those running Windows XP like me need to be aware that the Google Apps team announced that it will no longer support Internet Explorer 8 (and lower) on November 15, 2012. After that date those using Internet Explorer 8 will see a message recommending that they upgrade their browser. I run both Chrome and Firefox.


    I won’t pretend to understand it all but you’ve been very helpful. Thank you very much. I’ll try running the blog through Chrome or Firefox and see what happens. Thanks again.



    Best wishes to you and please do let us know how you make out when using Firefox or Chrome.


    timethief – I’ll be eternally grateful. I’ve downloaded Chrome and successfully uploaded a quick test posting – it worked fine and quickly.
    Thanks again for your help.



    Hooray! I love happy endings! You’re welcome and best wishes for trouble-free blogging.

The topic ‘very slow to upload’ is closed to new replies.