Need help? Check out our Support site, then

VideoPress HTML5 Problem

  1. I read about the new HTML5 capabilities in the VideoPress upgrade. I just tried to view videos on my blog using an iPad, iPhone and with Safari 5.0.4 (Mac OS X 10.6.6, plug ins disabled), but for each video, I get the message, "This movie requires Adobe Flash for playback," and the video doesn't load or play.

    Safari for these devices is HTML5 capable, so I'm wondering what's going on, or what I'm missing here.

    The blog I need help with is

  2. Have you considered approaching Staff for help?

  3. Do you have sharing disabled on the videos?

    Since downloading an HTML5-embedded video is by far easier than downloading a Flash-embedded video, we still use the Flash player for videos that have sharing disabled.

  4. That's non-obvious; I don't see that choosing not to provide a share/download link means that I wish to prevent downloading to the detriment of users from viewing the video.

    Where do I go to suggest an improvement?

    Secondly, even after enabling sharing, I find that my client's video works on my iPhone on his .com account blog but not the .org hosted site. (The videos work fine in a Flash environment). Is this deliberate or a bug, or am I missing some other non-obvious setting?

  5. Yes this seems wrong. I have the same problem. I want to have sharing disabled at least as far as not giving a helpful link embed dialog for anyone.
    I know they can get the video if they want but forcing me to have a "please steal my video sign" before it works on iphone etc seems crazy.

  6. OK, even with share on they do not work.
    More to the point neither do the videos at the videopress site, even the one in the blog post that announces support for html5 video.
    Using a iphone 3g, ios 3.1.2

  7. paulgregory & mgason
    Would you like to contact Staff directly?

  8. I just sent them a message, I will post the answer bak here if it helps

  9. Thank you. That would be appreciated as Staff only monitor these threads. :)

  10. Some further info, I guess I can not really pass more on via the support contact until they get back to me.
    Ipad 1 played the videos at the videopress site
    did not play the ones at my site

    I tried another iphone3 and visited the actual videopress site, it did not throw an error saying flash required BUT the video never played. The play button was there, when clicked it just stayed on the placeholder image and the play button was gone. I let the page fully load before clicking, I waited a long time and had a good wireless connection

  11. The plugin on self-hosted blogs still uses the Flash-based player, so the new HTML5 player is pretty much at this time.

    Hang in there, we're working on it!

  12. Ah that might have been a nice piece of information to have prominently displayed.

    I only made a account and signed up for videopress to get convenient video hosting for the mobile section of the site.
    The main site is completely flash, uses a flash media server for streaming, and redirects to the wordpress one just for mobile devices.

    For now my $60 is wasted.
    Any timeline for the plugin?
    I could just code my own html mobile site without wordpress. I only just started on the project and I already have full device detection setup with Tera-WURFL. To be honest though wordpress/videopress seemed like the simple solution.

    None of this explains why the advertising videos on videopess's own site did not play on 2 different iphones. As I said, 1 phone said this video requires flash, the other had a play button but just failed to ever start a video

  13. Unfortunately, I don't have a timeline yet.

    You purchased your upgrade only a few days ago, and you're welcome to a full refund within 30 days of purchase.

    Please contact us via if you'd like to do that.

Topic Closed

This topic has been closed to new replies.

About this Topic