VideoPress Still Using Old Blog's URL

  • Author
  • #1457909

    A couple of months ago I purchased a VideoPress subscription for the blog After a few weeks of inactivity I deleted my blog, not knowing that it would affect my ability to upload videos, via VideoPress, to my self hosted blog.

    I needed to get the videos back up and running, so I signed for a new blog at and re-purchased a VideoPress subscription for that domain.

    Now, when I try to “Add Video” via my self hosted blog, it errors out with a message: “ is no longer available.” I couldn’t find any documentation on how to update the URL that VideoPress is using and need my videos back up as soon as possible. I’ve now purchased two VideoPress subscriptions, please advise.


    The blog I need help with is



    I’ve tagged this for Staff assistance. Please subscribe to this discussion using the subscribe link in the sidebar if you haven’t already so that you will see their reply. Also, thanks for being patient while waiting as Staff are at a meetup and waiting time may be a bit longer than usual.



    Hi Jordan – The upgrades were still attached to the deleted site, but I’ve removed them now. Can you please try clearing your browser cache and then try to upload a video again? Let me know if you still have the same problem. A screenshot of what you’re seeing would also be helpful – you can upload it to the Dashboard of your new blog, and I can look at it there. Here are instructions for how to make a screenshot:


    Hi eurello,

    Still no luck. By clearing my cache I now get the login screen again when I try to “Add Video” (, but when I log in with my credentials, I get “ is no longer available” (

    It appears as though when I log into WordPress via “Add Video”, VideoPress is still associating my email/username with the old blog. How would we go about updating that?

    Thanks for the help.


    Hi Jordan – You mentioned you want to use VideoPress to upload videos to your self-hosted site, right?

    To do this, your site needs to be connected to your account through Jetpack. When enter at, it says your site is not connected yet.

    Here’s some information on how to get Jetpack running for your self-hosted site:

    Also, here are some tips on how to use VideoPress through Jetpack:

    I hope this helps! Let me know if you have any questions :)


    Thanks fabianapsimoes,

    I didn’t have my self hosted site connected via Jetpack the first time I used VideoPress and it worked great. Is this a new requirement (within the last month or so)?


    So you are using the standalone VideoPress plugin already. I’m sorry for the confusion!

    Let me check with our team what might be happening. I’ll be back to you as I have more information about this.

    Thanks, Jordan!


    Hey Jordan – Just wanted to let you know we’re still working on this issue. I’ll be in touch as soon I know more. Thank you!


    Hi Jordan – Thank you for your patience! We were on a company meeting last week, so response times were a bit tricky.

    It seems the standalone VideoPress plugin has been discontinued. That might be the reason why you’re having these issues. Can you try using VideoPress through Jetpack instead? Here’s some information about it:

    Thank you!

The topic ‘VideoPress Still Using Old Blog's URL’ is closed to new replies.