VidePress activation problem

  • Author
  • #1528052


    I am trying to purchase the VideoPress addon. I’ve arrived at the same page from both the Jetpack plugin (this is for a self hosted blog) and from the store within my account. In both cases the “Get VideoPress” buttons (at the top and bottom of the page) do nothing.

    They point to this URL:

    Please advise how to complete purchase and activation of

    The blog I need help with is



    update: it isn’t just video press … none of the “get” buttons on the store work (tried it in three browsers and two operating systems)



    Hi there, I’m very sorry your thread fell through the cracks.

    When you arrive at this page:

    When you hover your mouse over the button, are you able to select a site from the dropdown menu? You’ll need to choose the correct site for which you’d like to purchase the upgrade from that list. Please let me know if you’re able to do that and we’ll take it from there. Thanks!



    Yes can log in and on that page the other link icons work, such as ‘premium themes’.
    However both the link icons for ‘get video press’ do not work.
    The status bar shows ‘go to # on this page’ and they appear live when you hover over them but thats it, nothing happens.
    Hope it can be sorted soon.



    Hi Paul, in order to purchase VideoPress, you need to have a site, because that’s where your videos will be stored, even if the rest of the site isn’t used.

    I don’t currently see any sites on your account. Do you have any other user accounts it might be under?

    If you only have a user account but never created a site, you can create one here:

    Once you do that you should be able to purchase the VideoPress upgrade. Please let me know how it goes.



    will I be able to use VideoPress on my existing site or will it be limited to the one hosted on



    Yes, VideoPress can be used on self-hosted sites. For both self-hosted and sites, your video files are stored on the servers and transcoded there.

    You’ll also need to activate the free VideoPress plugin:

    From the VideoPress plugin FAQ:

    This plugin relies on a site with the VideoPress premium upgrade to host uploaded videos, transcoded video files, and related information.

    Can I use this plugin to host videos on my own server?

    No. This plugin requires a blog with the VideoPress upgrade and has no support for hosting videos on your own server.

    Just let me know if you have any other questions.



    Thank you Kathryn.

    I’ve managed to complete the purchase … and get through quite a few more obstacles to get it to work:

    • I installed, per your instruction, the VideoPress plugin. That seemed to work in the admin – there appeared a new add video button that worked, but viewing a post with an integrated video created an error message.
    • That error message seems to have been caused by the fact that Jetpack is already active – and it has VideoPress functionality integrated into it.
    • When I deactivated the VideoPress plugin the post with embedded video was presented properly, but then the admin functionality disappeared.
    • In the Jetpack VideoPress settings I was unable to select the blog I had created to activate VideoPress. I had to deactivate and reactivate the plugin, to reconnect it to my account for the settings to be set properly.
    • Now there still isn’t an add Video button, but I did find that the VideoPress functionality is integrated into the Add Media window.

    This has been a very unpleasant and difficult experience. Not something I am used to experiencing with WordPress. I hope this feedback helps you improve the experience so that others may experience less friction in activating a PAID service.



    Hi Paul, I’m glad you’ve gotten it working and I’m sorry it was such a rough process. I also want to apologize for not looking to see if your site is already using Jetpack.

    I really appreciate your feedback and have passed it along so we can improve the process for others in the future.

    Please let me know if I can help with anything else.



    one last thing (I hope)

    When I embed a video on the self-hosted blog ( and clear the “sharing” checkbox setting for the video (so that others cannot share this video) it also refuses to activate on the self-hosted blog. If I reselect the “sharing” checkbox it does activate on my site but then is also open for others to share.

    Is there anything I can do so that I, within my sites (those associated with my account), can activate videos without them being share-able by others?



    Hi there, if you leave the sharing checkbox checked, you can restrict playback to your own domain,

    In your dashboard, head over to Settings > Media, and add the domain in the box next to “Restrict embed playback,” as in this screenshot:

    More info here.

    Let me know if this does the trick.



    Thank you Kathryn
    All good so this thread can be closed.



    Great – glad you’re all set, thanks for letting me know.

The topic ‘VidePress activation problem’ is closed to new replies.