Visible, yet unvisible page!

  • Author
    Posts
  • #1041502

    gunsnwar
    Member

    Is it possible to make a page which is not visible on the bar at the top of the blog, yet it can accessed by anyone if they are type the URL of that page? Can I do it by using the custom menu widget?

    The blog I need help with is gunsnwar.wordpress.com.

    #1041610

    gunsnwar
    Member

    *invisible (horrible typo)

    #1041612

    raincoaster
    Member

    Yes, but you have to use a Custom Menu and leave that page off the listing.

    #1041619

    gunsnwar
    Member

    Ok, thank you!

    #1041661

    gunsnwar
    Member

    Well…turns out that there is still a problem.
    I made a widget (I deleted it now) and I used the custom menu which I made. There was a link there which successfully sent anyone to the page that was included in the custom menu.
    However, no matter what I did, that very same page was visible at the bar at the top of my blog. How I am supposed to remove it, yet allow anyone to access it through the custom menu that I made?

    #1041666

    justpi
    Member

    By creating a custom top menu. Details here:
    http://wpbtips.wordpress.com/2011/12/19/custom-menus/

    #1041681

    gunsnwar
    Member

    It took an hour to do what I wanted, but now it’s ready! Thank you a lot for the information! (Turns out I had to make two custom menus)

    #1041770

    You want to make a page invisible?!

    How the heck do you make a tab on the top leading to a static page visible? Or maybe the beach theme only allows one tab?

    I want to add a “contact” tab on the bar at top of the post area. God knows how I got the “Home”” tab up there. Anyway, I created a static contact me page (actually, several of them). I tried it as a widget and a custom menu. I checked that I wanted custom menu to appear as a tab and tried to add the static contact page to it.

    No success: http://susanjcunningham.com/

    I tried to follow everything on that wbptips link above.

    The contact page exists but there’s no way any viewer would realize that.

    #1041771

    PS I also tried doing this through the themes area under appearances.

    Elsewhere on this forum in regard to tabs, there is some mention of a “Pulldown” menu or something similar in the “themes location” area. I don’t have that. Maybe it doesn’t exist with the Beach theme.

    #1041772

    timethief
    Member

    How the heck do you make a tab on the top leading to a static page visible?

    Create a New Page > Dashboard > Pages > All Pages > Add New
    http://en.support.wordpress.com/pages/#create-a-new-page

    Create a custom menu > Dashboard > Appearance > Menus
    http://en.support.wordpress.com/menus/#creating-a-custom-menu

    Add the Page(s) you created to your custom menu > http://en.support.wordpress.com/menus/#adding-pages

    Troubleshooting – My menu isn’t appearing
    Go to the custom menu page in the dashboard Appearance > Menus and in the “Theme “Location” module at upper left select your custom menu from the pulldown and then click “save”.

    #1041773

    justpi
    Member

    Sorry, but my post includes all there is to know about menus. Quoting:
    • “Custom menus are created (and edited) in Appearance > Menus. Preliminary step: Click Screen Options (top right) and make sure Theme Locations, Custom Links [etc] are checked.”
    • “The regular top menu of a theme automatically displays links to all your published parent pages [etc].”
    • “Revert to regular top menu: Select the blank option from the Theme Locations pulldown, click Save.”

    So, since you only want to display links to your static page(s), you don’t need a custom menu: you only need to make sure the theme displays its regular top menu. You go to Appearance > Menus, click Screen Options to make the Theme Locations module show up, select the blank option from the pulldowns in that module, save.

    #1041774

    OK, Thanks! This is one essential bit I was missing:

    “click Screen Options to make the Theme Locations module show up, select the blank option from the pulldowns in that module, save.”

    I hadn’t clicked “Theme Locations.”

    The other issue–in case some frustrated person is reading this in the future–is that in the appearances dashboard, I had/have two menu clusters. When I was attempting to add the page to a custom menu, I was saving the wrong menu. I think.

    #1041775

    OK, Thanks! This is one essential bit I was missing:

    “click Screen Options to make the Theme Locations module show up, select the blank option from the pulldowns in that module, save.”

    I hadn’t clicked “Theme Locations.”

    The other issue–in case some frustrated person is reading this in the future–is that in the appearances dashboard, I had/have two menu clusters. When I was attempting to add the page to a custom menu, I was saving the wrong menu. I think.

The topic ‘Visible, yet unvisible page!’ is closed to new replies.