Visual Editor is no longer wysiwyg!!

  • Author
  • #1339971

    Hmm–not sure how to explain this! I’ve been working on a draft blog for a couple of days now.

    Today I brought up the draft blog and it looked completely different in the Visual Editor than it did yesterday. All the info was still there but the photos were not in the correct place and the formatting was different!! I don’t think that I’ve changed any settings.

    I clicked on “Preview Post” and the photo placement and formatting came up correctly!! So it’s like the Visual Editor is no longer wysiwyg!?

    I hope that this makes sense!!??

    Why is the Visual Editor not displaying wysiwyg anymore and how do I fix it?

    The blog I need help with is


    Same thing is happening to me….perhaps WordPress is working on something in the background?


    I’m having exactly the same problem. I’ve tried different browsers, emptying my cache, rebooting etc.
    It puzzles me that when I click visualize, it comes up correctly. I did NOT change anything on my computer recently. What could be happening?


    I’m using the Twenty Ten Theme.

    I did a little testing and it seems like the formatting on the Visual Editor is completely different than it is on the finished blog!?

    Let’s hope that WordPress can fix this!


    Same problem here! Glad to see I’m not alone.


    Still not fixed!

    Is there someplace else that we should be posting to alert WordPress to the problem?? I’ve tagged it with “bug report” already.



    I’ll tag this thread for Staff assistance. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.





    Would everyone posting into this thread please go through the following troubleshooting drill and report their results back for Staff please?

    If you are not running one of the browsers and versions listed at please try upgrading or switching first.

    If you are, please do these:
    (1) Try clearing your browser’s cache
    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see >

    (2) Make sure that you have third-party cookies enabled and JavaScript enabled

    (3) Try with all browser extensions or add-ons temporarily disabled.

    (4) Try enabling HTTPS:

    If you are not successful let us know exactly which browser (and version of it) you’re using by checking here if necessary and also post any error reports you get.



    I’ve just discovered the same problem reported by others, in draft mode visual editor is not functioning normally. Twenty-ten Theme, using IE 10. No problems before today (except that lately the edit page often, but not always, returns to “text” instead of “visual” as my default after I save a draft). Everything’s normal when I preview a draft post. Went thru the recommended steps, but problem still persists.


    I’ve cleaned all caches and cookies using Ccleaner. Tried three different browsers: Chrome (v27.0.1453.116 m), IE 10 (v10.0.9200.16618), Firefox (v22.0). Running Win7 x64 SP1. Javascript enabled and cookies also enabled. Using “https” as default.
    It was working until last week. I did NOT change anything. It must be something with WordPress itself.



    @violdam6 and ernestoplopes
    Thanks so much for providing your details.


    This is a bit beyond my expertise but here’s the results of following the suggested steps:

    I’m using IE 10
    1. Cleared cache = done

    2. I got a message when I went to the WordPress support website to check to see if my third-party cookies were enabled, it said “✗ Third party cookies appear to be disabled. Please follow the instructions on this page to turn them on.”

    When I followed the instructions (i.e. went to Privacy Settings/Advanced), there were three choices: Accept, Block and Prompt. It was set to “Accept”.

    I couldn’t figure out how to check that javascript was enabled but I’m the only one who uses this computer and I haven’t changed anything. Everything was working OK yesterday!

    3. Don’t know how to do this and it sounds scary to try :-)

    4. Changed to https = done

    I’m using IE 10 and Windows 8



    I’m also experiencing an altered Visual Editor. In my case, the font that shows up when I’m writing or editing a post is significantly smaller than it was yesterday. The font used in the previewed or published posts hasn’t changed. I haven’t noticed any additional formatting changes.

    (I went through the troubleshooting steps mentioned above but that didn’t help. I’m using Firefox 22.0.)


    Sorry that I have not responded, but cannot do the tests before tomorrow. However, with that said, based on previous responses, I suspect that it’s a WordPress issue.

    Additionally, the second post I published today ( after the noticeable change) did not show up on my site or on published posts. I did do a search for it, and the system says that it posted on 6/20/2013.

    Thanks for your help!


    I’m having a similar problem in the Twenty Twelve theme. I’m glad it’s not just me.


    I just checked my blog and it looks like it fixed!!


    Is there something that I should do to avoid this problem in the future?



    Problem seems to be fixed now. Thanks! But I don’t understand why in visual editor each time I save a draft, the visual editor window reverts to the smallest size (after I’ve extended it), the “kitchen sink” function reverts to “don’t show kitchen sink” and sometimes, but not always, the editor appears in “text” mode rather than “visual” that I normally work in. This has been happening for maybe a month or so. No big deal, but I prefer to work in the regular edit mode, and normally don’t care to use the “distraction-free” mode which limits functions and acts slowly when I switch back to the regular (non-“distraction free”) editor.



    Hi there, I’m glad to hear that the problem is resolved. Since it’s fixed for you, it’s hard for me to pinpoint what exactly was going wrong. If you encounter this problem again, please let us know and we’ll be happy to look into it further.

    @ violdam6, the new problem you are mentioning sounds like a different issue. Can you please start a new forum thread about this issue? Thanks!


    Thanks, rachelmcr. I’ve got another problem now. I “published” the draft blog that I was working on and it showed up on my site but —

    It came up only as a link that says “continue reading” instead of the full blog itself, like it normally does.

    I can start another thread for this but how do I alert someone from WorkPress to look into it?

The topic ‘Visual Editor is no longer wysiwyg!!’ is closed to new replies.